Servers by jDrones

Compass Calibration or lack of


(tim tamplin) #1

Hello all, I’m not where I want to be in knowledge of these pixhawks yet but I have learned a lot reading posts on this website. I have a boat using skidsteer with 2 thrusters , all that is good.I am able to run it manual thru the pixhawk cube, my problem and its a real pain in the butt, it the heading. I am using rover 3.4.2 and mission planner 1.3.55 and I do not have an option for live calibration. I have loaded every other mission planner from 1.3.50-1.3.61 and its the same. Now in my reading on here it seems they have done away with it and have the “mag calibration” I think its also called the “on board calibration” . When I click that button nothing happens. My boat shape heading is off by 135 degrees.I could change the AHRS boat orientation but I just dont think its the right thing to do as the pixhawk is facing forward.

Also not I’m not using the Here2 gps,it blows real bad and gets lock every 4 days,lol. I have been using a ttl convertor and bringing in a trimble proxt and that seems to work great for 3d fix.

any input would be greatly appreciated, Tim


(Peter Hall) #2

On-board calibration is more accurate than the old live calibration, you still have to rotate the vehicle in all axis you should then see the bar fill up.

If your vehicle its to big to do this you could try the new in flight calabration see


(tim tamplin) #3

Hi thanks for the reply, it’s as if that feature is not working. I will try again but I never see any green bars. Is there a Param to activate this feature? Thanks


(Peter Hall) #4

should just work, no need to change any prams, it may have issues if your compass orientations are set incorrectly


(tim tamplin) #5

If anyone has had the onboard mag calibration not work and found a solution please let me know.


(tim tamplin) #6

what do I need to dofor this in flight testing.i have a boat.


(tim tamplin) #7

i set the ahrs to 45 degree yaw offset and that seems to get the compass straight , I still cant get that mag calibration to show any green bars , just doesnt seem to be connected at all.


(Peter Hall) #8

if you could enable disarmed logging and get a log of your attempted calibration that would help in diagnosing the issue (try and keep the log a short as possible).

Thanks


(tim tamplin) #9

I never logged before, I found that param and enabled, I used mav link and found dat flsh logs on the flight data screen but im unsure after that.

  1. do I need to enable logging “start logging”
  2. anything else would help lol.

(tim tamplin) #10

ok I think I got it, telemetry log I can do?


(Peter Hall) #11

great, both data flash log and telem log if possible


(tim tamplin) #12

I don’t see any data flash logs, the folders are empty i’ll check a few things


(tim tamplin) #13

(tim tamplin) #14

are those logs ok? I connected and ran a mag calibration.


(Peter Hall) #15

Sorry, I missed this, nothing that obvious in the logs, Defiantly worth flashing the latest stable firmware. Other than that all I can think is to reset to default params and try the compass cal again.

The only other common issue is having something magnetic too close to the flight controller, ideally motors and things would be 3 or 4 inches away. If its not too much of a pain you could remove the flight controller and try and calibrate the compass while connected over usb, with nothing else plugged in .


(tim tamplin) #16

thank you for taking a look , i’ll look to change params, I have loaded 3 different rover firmwares and 10 different MP versions and it has always been the same nothing. i have this housed in a box no motors near it at all gps 3 feet away. it must be a param