Servers by jDrones

Compass Calibration error

(Jhanvi Prajapati) #1

I’m facing problem with compass Calibration. After calibrating it shows pop-up box with message “please reboot the autopilot”. How to reboot autopilot?

(Hari .P) #2

Remove power. ie unplug the USB,& battery.

1 Like
(Jhanvi Prajapati) #3

No that won’t work still the copter when takes off would turn upside down, it won’t fly steadily

(curt carroll) #4

Jhanvi, Welcome!
Please, give more information about your setup and post a log. If you post a log you will get answers if you do not no one can help you accurately.

(xingcheng ge) #5

Did you rotate the FC when you calibrating the compass? After the calibration you will need to remove all the power supply and re-connect the power and the usb, go to compass calibration page the there is three green number then calibration is fine, if not, It require recalibration

(Jhanvi Prajapati) #6

Yes I did rotate the FC along with compass but still same error . Can you add more highlight on three green numbers which and where are they!?

(Jhanvi Prajapati) #7

After reconnecting it again asks for calibration with same error please reboot the autopilot!

(xingcheng ge) #8

open the compass calibration page, you will see a three compass and orientation setup there are three number you will see

(Hari .P) #9

Please provide more delails.
post a photo of your setup.
which FC ?
which frame? ,motors?..etc
How is your external compass (GPS) mounted ?
Without details, it is guesswork !

(Jhanvi Prajapati) #10

Pixhawk FC , compass is directly connected to pixhawk. I have used servo motors . I’ll get u the picture of my drone !

(Jhanvi Prajapati) #11


This motors are used