Servers by jDrones

Compass Calibration Error 99

Hello Everyone!

I started seeing Bad Compass Health after updating to 3.2 (this maybe unrelated and just coincidental as well)

i tried running the calibration process; it doesn’t gather more than 3 samples and I see compass 1 & 2 show error 99.

I tried updating to APM 3.1 to use CLI (since its removed from 3.2) - compass init fails in CLI.

GPS is working as expected.

The 3.3v regulator seems to be working fine- multimeter says its operating at 3.28v.

Any pointers on what could be going wrong?

Hi

I have the same problem I think, Is this the same failure you getting?

are you calibrating the compass on the apm itself ? if not plug the GPS/Compass in then it will work

if you Calibrating the compass on the apm itself it dont calibrate i tried it 100 more times nothing seem to work but when i connect my GPs /Compass it then calibrates

Thank you! It works for me, but now I have a new problem, the next Step is to connecting the reciver, but nothing happing in the missionplanner,

What is the problem?

@Savage,
Since you have a different issue than the one in this thread, please start a new thread with your current issue.
Regards,
TCIII GM

Please help me.I calibrated it sucessfuly before but when i installed the new firmware in APM 2.8 it was showing error 99.Please help me i am not able to move further because of this problem.Thankyou

I also tried uninstalling and installing the mission planner.When i tried first time it worked!!!
But when i tried second time it showed error agian!!!
Now i am trying but not happening.
It was problem in mission planner.try uninstalling and installing mission planner.But calibrate it as it shows white points.dont miss it!
If you get the olution then please tell me.
I am stuck now

HI i am darshit bharucha only but using another account.
I solved the compass clibration error 99 by following these steps:
1.if you have connected the gps wire under the gps socket just remove from under that socket.
2.leave it for one minute.
3.then connect it in i2c socket.
4.then connect to your mission planner.
then disconnect and remove the usb.
5.then remove it from i2c socket and leave it for 1 minute.
6.then connect it to the socket below the gps again.
7.then connect it to mission planner.
8.then try calibrating your compass.

Thank you

Servers by jDrones