Compas#2 calibration out of view

Hi there

I am very new to ardupilot, and a new user on this forum. Hope someone can help me, with my problem. I am running arducopter 3.3.3 on my DJI F550 hexacopter.

When i try to calibrate my compasses, my compas#1 looks okay. But my compas#2 doen’t look that okay. The compas#2 is the internal compas, as i have tried disconnecting the external, and then the problem become compas#1…

When i calibrate the compasses the compas#2 is completely away from the view. Totally in the background. Not around the x,y,z axis as compas#1…

My board is a HKPilot32 from hobbyking. I think it is a okay board, and i don’t hope my board is broken. I have tried attaching pictures of my calibration view, and my drone, if there should be any interferrence.

When i fly, it flies relatively stable? Looking at the map, it is not fixed in the compas. It drifts a bit, like 1 or 2 degress forth and back within a couple of minutes… Is this okay? It also returns to launch quite precise. But the view in mission planner doesn’t look like the things on youtube and other tutorials.

I know the pictures show i am at home, but the error is there on the field too.


No one that can help? :frowning: