Commands to repeat an automatic mission

Hello,

Is it possible to don’t disarm copter in auto mission after a return to launch command and stop propellers?

The idea is to should do a GPS track a several time like this commands:

Nobody has any idea ?

You want to land and them take off again and repeat mission?

Hello,

Yes, this is it

LOITER_TIME will not do what you want. After it executes the RTL and touches down the props will spool back up to hold position even if it’s on the ground. However, the following using the DELAY command works perfectly. After the 1st mission loop it holds on the ground for 30sec and then executes another loop and then holds on the ground 30sec before disarming. I rarely use RTL in a Mission anymore. I prefer a Waypoint and a LAND command.

3 Likes

Hello,

It’s a solution, but I would like my quadcopter landing in a safety zone precisely at the same place where it had take off.

The idea it is to do a first mission loop, copter landing at the same place where it had take off, his propellers stop, have a delay by example one hour, and it doing a second mission loop, etc…

That should work. Be sure to read the guidlines for the DELAY command with respect to elapsed or actual time settings!

Yes, you have reason, I will go use condition_delay.

I will go do a try, but I think what after return to launch, copter disarm.

I tried to do this commands, but it’s doesn’t work.
It’s strange, when my copter want execute “land command” it pass in failsafe mode.

Strange because I ran the mission I posted, which has the same commands as yours, several times and it worked. I’m not sure what you mean by “it pass in failsafe mode”? Post a log.

Hello,

Today, I made a first flight with the mission below and I still have the same problem, my copter goes into “RTL” mode.

I made a second flight with a takeoff, three waypoints and a land and always the same, my copter goes into RTL mode.

I made a third straight flight with just a “takeoff” and “waypoints” and it worked well.

My copter interprets the command “Land” as “RTL”.

Attached my mission with the logs link. I looked at them but I do not see where the problem comes from, I have version 3.4.4 of APM copter.

https://drive.google.com/open?id=0B4_NMRWainOKRWJsaDctbDBmcEU

After research, I still have not found where the problem came from.

I will update the firmware with APM Copter 3.4.6 and see if this resolves the problem.

Hello,

I have update the firmware to APM Copter 3.4.6 and I have always the same problem.
My copter interpret command “Land” like “Rtl”.

I don’t know if I am alone to have this problem ?

Can someone help me ?

I have attached my logs.

https://drive.google.com/open?id=0B4_NMRWainOKUmxySW1BR0VxTkU

It is RTL because of a Terrain Data failsafe. It never reached the LAND command. Do you have “Terrain” selected in the flight data screen? If so select “Relative” and try again.

You have TERRAIN_ENABLE param enabled, try to disable.
I try the mission today and work fine with LAND command, with RTL command the copter lands and disarm, not repeat the mission.

TERRAIN_ENABLE is on (1) by default. What’s significant is if “Terrain” is selected while planning a mission.

1 Like

yes, correct dkemxr I check mine and is enable too, the strange is that Dorian photos looks as RELATIVE was choose; if He disable from params it can´t take effect if He don´t need terrain?
I use the latest Beta Mission planner and latest beta copter for this mission. Try to update M planner just in case.

Yes you are right, I didn"t notice that.Odd that he’s getting terrain failsafe The log shows that’s why he"s getting RTL but its unclear why the failsafe…

Thanks for your answers,

I confirm what Relative was well selected while planning mission.

I work with this copter and firmware version (APM Copter 3.4.4 and now 3.4.6) since many months with only waypoints and it had good.

I had try with “land” command recently and this is at this moment what I have seen this “problem”.

I have change TERRAIN_ENABLE at 0 and this is good !

I don’t understand why it’s don’t work if TERRAIN_ENABLE is activated, I don’t see the relation ?
TERRAIN is a database of “ground altitude”, why it can’t work with “Land” command ?

1 Like

Perhaps the issue is on your Mission planner vers? you update it?