Command was denied by the autopilot

I am prepping a new quad for flight, and wanted to run a motor test to run individual motors from the Pixhawk to confirm all the wiring. When I use Mission Planner / Initial Setup / Optional Hardware / Motor Test, I get and error box saying “Command was denied by the autopilot”.

I am running MP 1.3.9 Build 1.1.5346.13591. This loaded Arducopter V3.1.5 into the Pixhawk, as best as my notes can tell.

I have run all the calibrations, and can arm and run the motors using the RC throttle joystick, it’s just that they all run and I want to see it go around the quad before I try to fly. I am arming it before I try to run the motor test. I have tried a bunch of different throttle commands in the selection box, up to 15%. I have tried it using the 3DR TM modules and also directly connected to the Pixhawk with a USB cable, same results.



I have the same issue with my 3DR Y6 kit. ‘command is denied by the autopilot’.

Have you solved the issue yet?

Same issue here, new quadcopter build with APM 1.6 clone. Fresh flash to 3.1.5, connecting via Mission Planner (Windows 8.1) over 3DR telemetry.

Where can we download the 3.1.4 firmware to see if that get’s us around the motor test issue or is this a Mission Planner issue (a case of the egg before the chicken) and we’re waiting for the AC firmware to catch up?

Have rolled back to the previous AC 3.1.4 firmware without success, same issue, trying to update to AC 3.2 to see if this is resolved and will indicate the issue is with Mission Planner.

Updated to AC3.2-RC12, motor test now works fine, I needed to increase the throttle to 19/20% to get the motors to spin. Now run into another issue; Bad Compass Health () on external compass with APM 1.6 clone board. Might just flash back to AC3.1.5 till 3.2 is official and these kinks are worked out.