Command servo from mission planner

Hi everybody,

I would like to command my camera (pan and tilt) from the joystick or keyboard through the telemetry.
(I cannot use APM input : CH5 to CH8, I already use it for other stuff)

To do this, I tried to used DO_SET_SERVO (do_command) on mission planner code (Joystick.cs) but it didn’t work like I was expecting. The return value is always MAV_RESULT_UNSUPPORTED.

If I 've well understood, this is because the do_command works only during mission between two waypoints.

I would like to know if there is a way to do this in the mission planner by using a MAVLINK comnand or If I have to change first the arducopter firmware ?

I watched a bit the firmware code, there is a method called “do_set_servo”.
Should I have to used it in a new MAVLINK message ?
Or should I have to use “set_overrides” methods ?

I would be grateful if someone could give me a clue on this issue.

Thanks in advance.


I haven’t tried this myself, but possibly (as a work-around) you could make a copy of the same WAYPOINT and insert your DO_SET_SERVO command between the two same GPS coordinates.

Just a suggestion.

Terry :ugeek: