Cheerson CX-OF and Kakute f7 AIO

Hello,

Im struggling to launch CX-OF on my Kakute F7 FC.
I was configuring autopilot according to wiki page , but Im not able to assign flight mode FlowHold.
When Im trying to use this FlowHold mode I have no such mode.
I know that this FC has firmware limitation , so besides stable copter 4.2 I was creating dedicated firmware. Unfortunately no changes. Any ideas how to launch it or how to build working firmware ?

thanks

my custom build :
https://custom.ardupilot.org/view?token=copter:KakuteF7:d2d5aada092f2cc197bb0d67db458eabc45f8a41:745dc39c1eec4b559d26a8b65aa510ac

All param list:

All_param_16_8_2022.param (20.1 KB)

Appears to be a bug in the build process. I’ll fix it up

Thanks.
And just for my curiosity, how did you spot this bug ?

The flowhold mode code is at ardupilot/mode_flowhold.cpp at master · ArduPilot/ardupilot · GitHub

Note the #if !HAL_MINIMIZE_FEATURES && AP_OPTICALFLOW_ENABLED at the start of the file. So the mode is only compiled in if HAL_MINIMIZE_FEATURES is false AND AP_OPTICALFLOW_ENABLED is true.

The HAL_MINIMIZE_FEATURES is automatically set to true for all flash-constrained boards (Such as the Kakute F7). See ardupilot/hwdef.dat at master · ArduPilot/ardupilot · GitHub for the Kakute F7 config.

Thus the flowhold code will never be compiled in flash-constrained boards. Obviously a bug, as users should be able to select this as a feature in a custom build.

The custom build configuration and website are relatively new features in ArduPilot, so some build features may have been missed (such as in this case).

Thanks for reporting this!

ok. Thanks for feedback.
Just let me know when you fix it, and I will try.

Thanks

It’s now been fixed. You can enable it via Mode -> Enable Mode Flowhold option on the custom build site.

For reference, the patch that fixed this is at: Copter: Make mode flowhold a build option by stephendade · Pull Request #21466 · ArduPilot/ardupilot · GitHub

Thanks Stephen , now it works . now need to deep dive on configuration.