Check BRD_TYPE:Unable to detect board type

I purchased my unit from RobotShop last month. After updating my Pixhawk 2.1 to the latest firmware using mission planner, I get this error:
Check BRD_TYPE:Unable to detect board type.

Even after manual setting the BRD_TYPE to 3, I still get the error and I changed it back to 0.

Any suggestions ?

I do thank you for your time.

Install ArduCopter-v3.px4 , maybe it helps.

For your help i load fw AC3.5.2 ArduCopter-v2.px4

and Now I am getting “Check BRD_TYPE”.

So when i change back to fw AC3.5.2 ArduCopter-v3.px4 , the error disappears.

Also i notice BRD_TYPE is dected based on fw type upload.
It detects board type as 3 if you upload ArduCopter-v3.px4.

Hope it helps!!

Thanks RQ. I had tried various versions of firmware to no avail. I
contacted the manufacturer. I am getting the unit replaced by RoboShop
where I purchased it. They have excellent service!

I appreciate the suggestions.

Good to hear abt unit replacement , hopes it would come with pre-installed firmware.