CHECK BRD_TYPE: Failed to update (CUAV V5+ Arduplane 4.0.5)

I have a Flight controller CUAV V5+ and it has crashed on a little wet sand field.
After the recover it, I tried to exchange firmware to re-install the firmware via Mission Planner.
However, after the recognition of comport and connection, I have got following message. (As a matter of fact, the recognition of comport during firmware installation was also not smooth. The installation process was stopped at Searching Comports. When I reconnect the USB cable, the comport number was recognised at different number.)

  • CHECK_BRD_TYPE: Failed to update I/O Firmware

At first, I revised a full parameter list to change the BRD_TYPE parameter to 0 (AUTO) and rebooted but, it has not been disappeared.

Also, I tried to get LEVEL calibration but, the ‘Failed to LEVEL’ message I got.

I think the Flight controller is damaged…
So Sad…

Was the cause of the crash the flight controller too or for other reasons?

Good day, did you try set the brd type as 1?
or try flash the board with the px4 firmware and after this flash again ardupilot…

Hi Dave,

I will try this one. I have not set the brd type as 1.

Thanks for advice.

Actually, I hope not.

I would like to upload flight log file as below: (Google Drive Sharing)

The airplane flew very well before the base turning at last.
But the airplane lost its speed during the turn and it is fall as like stall status.