Servers by jDrones

Check BRD_TYPE:Failed to init CubeBlack -sensor

hello… this is my first contribution here, i’m a beginner in pixhawk,… I have a pixhawk 2.4.8 which was working fine, but yesterday, I tried to connect it to the laptop it refuses to arm and gived me the message:
check BRD_TYPE:Failed to init CubeBlack -sensor
and it didn’t give anysound and the main light is not lighting.
when I connect it to the battery, the main light gives a solid red without any sound.
may anyone help me please?

I tried to clear the EPROM, I can’t too

thank you very much… I will post there, but if you have a solution, I will be gratefull

If you have a Pixhawk 2.4.8 you won’t get any help there.

Where may I get a help?

You must have the wrong firmware.
Dave is right

I installed the official firmware for copter… Since I’m connecting it to a quardropter… What might be the wrong?

Try loading plane then copter again.

I did… I tried… But it didn’t work

Not sure if it shall help but I think you need to install one of the earliest firmware like this one: ArduCopter-v1.apj (904.7 KB)

I am not sure if it is important or not, but this file name extension is px4. change it and try to load it using custom firmware.
HTH,
gal

This isn’t the 1st time we have seen this. Try QgroundControl and select the Arducopter current stable. If successful then connect with Mission Planner and see if it installed Fmuv2 on the messages screen which is the right version for that FC.

thanks all for your support, I just tried several times to install the official firmware, but nothing happened, but yesterday after midnight I tried for the last time, using the same procedure, and it worked… I don’t know what was the problem… and I didn’t do anything new, and I don’t know how it suddenly worked…

@dkemxr @gnitzan

Following an updating to Plane 4.0.3, I am now getting the same warnings as described above re brd_type and io firmware, on the same board as is mentioned (clone pixhawk).

Mission planner sees the board as a PX4v2, can NOT reflash to any other firmware - tried "custom firmware upload of copter 3.6.9, rover 4.0, and plane 3.6.9, nothing will load properly.

Also tried uploading pixhawk 1 firmware (didnt work), and power recycling with safety switch, which didnt work either.

Any ideas? Is it possible to force a different board type into MP?

Try QGroundControl selecting Arducopter stable.

I’ll try that - thanks

Servers by jDrones