Channel Values from RC Tx are 'None' on Raspberry Pi from Pixhawk 6C

I am getting Channel Values from FrSky QX7 transmitter (Tx) as None for all the eight channels on my Raspberry Pi (RPi). I have calibrated it in APM and see switches and sticks responding to my input on my Tx. However, on my RPi, I am not able to obtain channel values. I am using DroneKit’s vehicle.channels API on RPi connected to Pixhawk 6C (Pix6C). I have connected the FrSky R10 Pro receiver (Rx) to PPM/SBUS RC port on Pix6C, and Pix6C and RPi are connected to each other via USB.

Note: with the exact same setup and replacing Pixhawk 6C with Pixhawk 4, I am able to obtain channel values from Pixhawk 4 on my RPi. Also, I have tried re-binding my Tx-Rx but didn’t work.

Any idea why I am getting channel values from Tx on my RPi as {'1': None, '2': None, '3': None, '4': None, '5': None, '6': None, '7': None, '8': None}? Thank you very much for your time and help!


Hello, would like to ask if you have solved this one. I have the same problem

Solved this one.

Referring to this GitHub Issue

I set both my Serial 1 and 2 procotols to 1 instead of 2. I connected through Telem 2 with 921600 baudrate. You can probably read the channels from then on.

Hope it helps!