Servers by jDrones

Chan 6 Opt for WP Speed not working


(OtherHand) #1

This is for Mission Planner 1.3.10, build 1.1.5369.11976

I want to make my WP Speed adjustable from 400 cm/sec to 1200 cm/sec via the channel 6 knob via the Extended Tuning screen. However the “Min” and “Max” fields will only accept values below 32.7670. Any values input above that value simply shows 32.7670. In addition, the WP Nav Speed always remains at zero. There is no response to knob changes.

I tested my setup by setting other Chan 6 options to my knob and they respond as usual. But the WP Nav Speed adjust is broke.

As another data point for this problem I went into the Full Parameter List and manually changed TUNE_LOW to 400 and TUNE_HIGH to 1200 and wrote the parameters. Returning to the Extended Tuning screen and doing a refresh, the tuning range min is displayed as 0.400 and the max is displayed as 1.200. And no matter how I adjust my chan 6 knob, the displayed WP Speed stays at 0.

It seems like a decimal place has slipped a bit in the code.

Edit: PS, This is running 3.2 RC10 on a Pixhawk.


(OtherHand) #2

As a followup to this, I’m now wondering if it’s a bug in 3.2. I tried using APM Planner 2 to set Chan 6 as a WP Speed control and got virtually the same results as Mission Planner. Slight differences in the decimal placement, but the same 32767 overflow-type number.

I sure would like to get an adjustable WP Speed working.


(OtherHand) #3

And…followup number 2. Now I’m not a code guy, but I may have figured out what the issue is.

When Randy implemented the initial WPNav routines in March 2013 the WPNAV speed was labeled as WPNAV_Speed.

However on April 8, 2013, Randy changed that variable name to WPNAV_WP_Speed in both AC_WPNav.h and AC_WPNav.cpp.

I’m not seeing anywhere in Mission Planner where that variable label was updated to include the “WP” in the middle. But then my coding ability sucks and could well be wrong.


(OtherHand) #4

I’m going to bump this back up. Or perhaps I’m not posting this in the correct forum?


(OtherHand) #5

There was a post by Randy that 3.2 RC13 included a bug fix that consisted of, “fix ch6 tuning of wp-speed (was getting stuck at zero)”. So I loaded RC13 thinking this would fix the problem I raised here and I could mark this solved. Unfortunately, it did not.

I’ve attached a couple of screen grabs to better show what the problem is and hopefully garner some attention. The first grab shows Channel 6 set up to adjust the WP Speed from 500 to 1,500 cm/sec. This grab is before I hit the “Write” button.

After hitting Write, I turn on my RC Tx (with chan 6 set to a knob) and hit the “Refresh” button. The After screen grab is what I get. Notice the new values of 32.767 in the tuning range highs and lows and the “WP Nav” Speed remains at the previous 1,000, but is now grayed out. As an amusing extra bonus, even after resetting the channel 6 tuning to None and rewriting, the “WP Nav” Speed remains grayed out and won’t let me write to it until I power cycle the Pixhawk.

This seems pretty hosed up.


(jakekc0uxp) #6

your not the only one im wanting this too and does the same thing


(jakekc0uxp) #7

minimum 0.0010 and maximum 0.4000

play with those numbers

I am going with 0.0300 and 0.3800

when my pot is center I am showing 200 cm per second
minimum goes to 30 cm per second and max goes to 380 cm per second


(Splinter) #8

I’m also not able to get any of this working the way described above…


(rmackay9) #9

If the tune min and max are specified in m/s it should work. So set min to 1.0 (for 1m/s) and max to 15.0 for 15m/s and it should work.


(Splinter) #10

Randy, if I set these values directly in the parameters list, they translate to 0.01 and 0.15 in the MP Extended tuning tab, so that seems ok.
Also, channel 6 in the radio calibration screen is responding to my TX knob changes.
Then, if I change the Tx ch6 knob and refresh the extended tuning tab screen I do not see the WPNav panel Speed value change, which I would expect.
I don’t know yet if it’s working in the air, in my case it just doesn’t seem to work in MP. Are there other things I could test/try?
Regards and thanks for your help!


(OtherHand) #11

I’ve upgraded to the 3.2 full release and Mission Planner 1.3.11 and it’s still not working properly. But it’s about halfway there.

To test I set the Channel 6 range per Randy’s suggestion, 1.0 and 15.0. With Channel 6 dialed to its minimum I indeed get a WPNav Speed of 1000. However when I start increasing the knob weirdness occurs. Somewhere just barely past half dial the WPNav Speed maxes out on the Extended Tuning display at 8658 and grays out. I’ve attached a screen grab show this condition. Turning my Channel 6 knob further doesn’t do anything. Reducing the knob eventually returns it to a range where the display again changes. So it looks like Something’s wrong with the upper limit. Lower limit seems OK.

And FYI I’m not using any sort of rate or expo on my Channel 6 knob.


(Splinter) #12

I got it working! I’ve tried different items from the Ch6 dropdown. Changing the dropdown from NavSpeed to Loiter speed didn’t do anything either, but once I’ve changed to (and saved and tested) ThrottleKp (or I guess any other would do) and back, all worked.
Then changing back to Nav Speed ‘unlocked’ the thing, and now it’s behaving as expected. Unfortunately I can’t reproduce the ‘lock up’ yet, also not by going back to earlier saved param lists. So clueless how it happenend, but solved for me.
ps. Min Val = 0.25, Max Val = 0.7 in MP now, maybe try that OtherHand…


(MarkM) #13

Have you tried using the latest beta version of mission planner as that seems to be more aligned with AC3.2?


(OtherHand) #14

I had been using the beta versions of MP hoping that a fix would have been included, but none did. The version I reported on in my most recent post, which half worked, was the full version released just a few days ago.


(OtherHand) #15

I’ve upgraded to the latest 1.3.12 Beta build of MP coupled with the Full Release 3.2 and it appears the function is now working as it should. Solved.


(Umeda) #16

Hi Randy,
According to the Copter::tuning() function in ardupilot source, Ch6 tuning related to the WP_SPEED does only set the speed_xy (AC_PosControl::set_speed_xy(float speed_cms)) and couldn’t find that it takes effect for the copter parameter WPNAV_SPEED. So how we can get the target speed set by the Ch6 knob via the mavlink? If I have missed something could you please point me to the relationship between the set_speed_xy function and the WPNAV_SPEED parameter.
Thank you.