CH6 DisArm signal causes change in Flight Modes on CH5?

Final setup for my HexCapitator.

A photo:


PixHawk 2.4.8 (PixHawk 1, FMU v2) running ArduCopter, using Mission Planner.

Checking out my Transmitter switch settings using Mission Planner.
I have SA set up as an Arming switch: High = Arm (Request), Low = Disarm

CH 5 is controlled by SD AND SG, six modes.
6 Flight Modes from 2 Switches

I try to PreFlight in Stabilize Mode, but when I check the SA Arm/Disarm response in MP, I see the Flight Mode change from Stabilize to RTL.

I have pored over Parameters RCx_OPTION and CHx_OPTION for all switch-controlled Channels, even made a spreadsheet to keep track of them.

HexCapitator spreadsheet (.ods)

I cannot find any reason for this behavior. Has anyone else noticed a similar issue? All comments welcomed.

I verified that the PWM signal on Ch5 (flight modes channel) are not affected by changes in Ch6 PWM signal.

That leads me to believe I’m triggering some logic in the Copter firmware.

Provide a .bin log file, you can set LOG_DISARMED to capture the entire process

Those automotive style crimp connectors on the motor wires wont do you any favours - best to solder and heatshrink them and lose the connectors entirely before they lose you whole aircraft.

Thanks, even that request is like a signpost. I’ll see what I can do.

I agree, and thanks for reminding me about it! :vulcan_salute:

I don’t want to watch this expensive toy fall out of the sky, or become an airborne fireball.

I expected to do a solder joint and heat shrink after I verified correct rotation. However there was a time-consuming learning curve to get the motors to spin.

More later.

This makes a good case for BLHeli_32 ESC’s . Solder-em up and change the rotation in firmware. :slight_smile: And then don’t worry about ESC calibration…

BLHeli_32 is cool stuff. Maybe next build…when BLHeli_64 is all the rage, and they haven’t yet sold all the BLHeli_32s in stock? :smile:

Latest news: After reading a bit about ECL and EKF and another deep dive into Parameters, it appears that a failsafe state was triggered.

Among other actions, I turned off FS_THR_ENABLE, which was triggering messages like “No RC Receivers” (some Radio failsafe? Radio signal was okay) and switching Flight Mode to RTL when the throttle was =< FS_THR_VALUE.