Can't Write New Compass Params to 2014 3DR RTF Quad

2014 3DR RTF Quad running stock FW/Params except for radio calibration changes: Don’t know if this issue is HW or SW, but it seems like HW so I’m posting here.

I was looking through all the params using MP 1.3.4 and noticed the compass offsets as -91.64113, 2.031883E-43, 0. From everything I’ve read, this doesn’t look right, especially from an RTF Quad.

I ran the compass calibration using MP 1.3.4 and got -91.64113, 23.39725, 157.8545. These look good and stayed very close after three tries. I wrote the parameters back to the quad okay. I can disconnect, close MP, reload MP, connect, and the params are still the same.

HOWEVER, I turn off the quad (disconnecting the USB cable providing power), wait 30 secs, replug the USB, connect with MP, and the compass offsets are back to -91.64113, 2.031883E-43, 0. The write happened but was lost when the quad was powered down.

  1. HW issue?
  2. User issue?
  3. What are the 2014 RTF Quad compass offsets supposed to be? Seems like they are wrong, at least the ones on my quad when I got it.



Update: hmmm, appears as if there’s a marginal voltage issue someplace. I redid the above experiment but using the battery to power the quad, not just the USB, and the params took this time across power downs. Don’t know if it’s a param write issue or subsequent read issue. And, as far as I can tell, only the compass offsets are affected. The pixhawk works fine with only the USB powering it except for this issue.

If it’s not “broken”, then I need to be carefull to only read/write params with the battery powering the pixhawk.

Does this sound normal given no other symptoms?

Are the original 3DR RTF supplied compass offsets of -91.64113, 2.031883E-43, 0, valid? Maybe the factory had the same issue. Either they did NOT properly setup the RTF quad as advertised, or they had a similar issue. Given nothing has changed in the HW or FW, the offsets should have been close to what the calibration says now of -91.64113, 23.39725, 157.8545

Please advise.


[mf]Hardware/RTF Quads[/mf]

There were some issues with a version of mission planner and the compass calibration, so please try the latest version of mission planner. … ngeLog.txt

Pixhawk offset values may be greater than 150 and less than -150.

I’m using MP 1.3.5 and have been following the compass calibration issues. I did see where a post said that Pixhawk offsets can be greater than 150. So, if my offsets are really in bounds for a Pixhawk, then MP needs to be updated to not “fail” the high compass offsets under “log analysis”, as well as the Wiki to reflect the correct values (for Pixhawk).

Thanks! - Tim


With your MP 1.3.5 you still can’t write new compass params? The original offsets are not valid in my opinion.