Can't use waypoints with SBF GPS enabled 3.4.2-rc2 No Terrain Data Error

While tracking down a problem causing the Pixhawk to crash I started to focus on the “FS: No Terrain Data” message I was getting every time I selected Auto on the Tx.

All parameters relating to terrain have been set to 0.
Mission Planner the height is set to Relative for waypoints.
With NO waypoints in the PH I can select Auto, no error generated.
Add one waypoint and I immediately get “FS: No Terrain Data”.
Remove the waypoint and I still get the message, I have to reboot to clear it.

3DR Pixhawk w/Crius HV Power Module
BEC into output rail w/Zener over voltage protection
MavToHOTT telemetry module in Comm2
Septentrio RTK GPS in SBF mode
Graupner Tx and Rx
T-motor U5 motors w/T-Air 40A ESC’s
T_motor 15x5 Props
1000 size Octo frame
6S 22000 battery
RFD900 Telem radios

Log of Rejected Auto


Thanks again for testing. I looked at your logs and tried to reproduce the issue but I couldn’t.

It’s possible that somehow the waypoints are being set with their altitude type as “Terrain”. Unfortunately we don’t log this particular aspect of the commands. I’ve created an issue to track this.

I’m wondering if you can double check that you’re using a recent version of the Mission Planner and that on the flight data screen you definitely have “Relative” selected?

These are the steps I tried to do to reproduce the problem:

  • connect to Pixhawk from Mission Planner
  • set TERRAIN_ENABLE to 0
  • wait until vehicle has GPS lock
  • create a small mission with just a takeoff and a single waypoint command and the altitude drop-down set to “Relative”
  • arm vehicle in Loiter, switch to Auto and raise throttle

After doing the above I could not get the “Failsafe:Terrain data missing” message to appear. If I set the altitude drop-down to “Terrain” then the message would correctly appear.

I’ve had a chat with Michael Oborne and he says this is caused by an issue with the SBF GPS driver which is fixed in this change which will go out with AC3.4.2:

We will be pushing out a release candidate for AC3.4.2 within a week. Until then you can actually test with master but please be careful if you do that because there are a lot of other changes that have gone into master as well that won’t go out until AC3.5.

Sorry for the troubles!

Thanks for looking at this @rmackay9

I had downloaded the latest Mission Planner update for this.
Made sure the drop down was in Relative.
Deleted all waypoints from memory and rebooted and auto was selectable.
Created one waypoint and the message reappeared.

I cannot arm in Loiter as I get “GPS horrid error >5” messages.
Still trying to track this one down.
I get the FS: No Terrain Data message switching to Auto even when disarmed.

I will try with master but I always seem to get myself into trouble trying that.:confounded:

Currently using AC3.4.2-rc2

I have found that the FS:No Terrain Data happens whenever a GPS mode is selected (Auto in my case) and a problem exists with the 3D Fix.

I have all terrain use turned off, have made sure that terrain is NOT selected in Flight Plan screen.

The message has been noticeable due to the GPS Horiz error generated by the Septentrio RTK GPS in SBF mode.
I have just duplicated the error using as 3DR Ublox GPS but indoors, so no suitable GPS lock.
Switch to Auto and immediately get “FS: No terrain data”