Can't upload ArduRover firmware in Pixhawk 5X - no firmware available

Hi to all,

I’m trying to install the ArduRover 4.1.2 firmware on my pixhawk 5x by Holybro but I’m having problems since Mission Planner says that it cannot find the proper board model.

I’m able to connect the board to mission planner and I can see the heading and the GPS position on the map. Then, I disconnect it and go to “Install Firmware Legacy”, it ask me if it is a Linux Board and I say NO, then ask me if it is a Pixhawk and I say YES and then it says “Upload ChibiOS” and I say no.
After this, it tries to download some information from internet and then it gives this error:

ERROR: firmware not suitable for this board fw:9 - board:51

My board should be: PX4 FMU v5X.x from Auterion.

What should I do in order to use ArduRover? I should use my pixhawk board for a tank steering rover.

If I use the “Install firmware” option it detects my board as:

board type 51 brdrev 0 blrev 5 fwmax 2064384 chip 10016451 chides STM32F7 on COM5

but when I click on ArduRover 4.1.2 OFFICIAL it says that there is no firmware available for this board!

Thank you!

1 Like

I believe you will have to load V4.2.0-Dev (Master/development) firmware for that board at this time. Hit Ctrl>Q from the Install Firmware screen in Mission Planner to load the Dev version or download the .apj from here and use the “load custom firmware” button:

1 Like

I tried both solutions and it tried to download something from internet but it always says:

ERROR: bootloader reports INVALID OPERATION

If it’s downloading anything, you have not correctly selected the custom firmware option.


And just a note when it said “Upload Chibios” on your previous attempt you should have said yes.


Unfortunately, it doesn’t ask me anymore the option: “Upload Chibios”.

At the moment, if I use CTRL+Q to enable the Rover 4.2.0 DEV or if I upload a custom firmware, I always get this message:

and it just asks me if:

  1. it is a linux board → I say NO
  2. if it is APM 2+ → I say NO
  3. if it is a PX4/PIXHAWK and I say YES
  4. if it is a PIXHAWK

when I click on YES at step 4, then I get the previous screenshot.

If I try to directly upload the Rover 4.2.0 DEV by clicking on the icon, then I get the error on the bootloader:

ERROR: bootloader reports INVALID OPERATION

Sometimes, when I try to upload the firmware, I can hear a beep coming from the board.

I recorded a short video to show you the problem.
Sorry for the video quality.

It looks like you downloaded and are selecting for load the _with_b.hex file not the ardurover.apj file I said.


And … as you can see here Added support for Pixhawk5X by tridge · Pull Request #19034 · ArduPilot/ardupilot · GitHub it is still work in progress.

1 Like

I also selected the apj file, but the result is always the same since I get the same error, unfortunately.

So the only solution is to buy another board?
I purchased the holybro pixhawk 5X just few days ago because I thought it was the most recent one. :pensive:

I wonder if it’s a bootloader issue? If would have come with the PX4 stack. Try updating it maybe?

1 Like

I tried to use the “bootloader update” function but it doesn’t work since it gives errors: sometimes it says that it cannot recognize the board while other times it gives the bootloader error with invalid operation.

Is there a way to force the upload of the bootloader? May be with an external programmer?

Do I need to short circuit any pins in order to make the board enter into programming mode? May be the process fails because of this.

Try QGroundcontrol to flash the Dev version of Ardurover.

1 Like

I used the QGroundControl to upload the PX4 Pro Stable Release and this procedure gives no errors:

QGroundControl can upgrade the firmware on Pixhawk devices, SiK Radios and PX4 Flow Smart Cameras.

All QGroundControl connections to vehicles must be disconnected prior to firmware upgrade.

Please unplug your Pixhawk and/or Radio from USB.

Found device: PX4 FMU V5X

Connected to bootloader:

Version: 5

Board ID: 51

Flash size: 2064384

Plug in your device via USB to start firmware upgrade.

Downloading firmware…


Download complete


Successfully decompressed parameter_xml

Successfully decompressed airframe_xml

Successfully decompressed image

Erasing previous program…

Erase complete

Programming new version…

Program complete

Verifying program…

Verify complete

Rebooting board

Upgrade complete

If I select ArduPilot and then Rover and I click OK, nothing happens!

However, I see that QGroundControl has an option in the air frame and lets you choose the Generic Ground Vehicle option. Can it be a solution?

I used QGroundControl to upload a custom firmware and I selected the ArduRover from the latest firmware available for the pixhawk 5X and I think I did it!

Now, Mission Planner successfully recognizes the board as ArduRover V4.2.0-dev!

So, if someone else has my same problem, I solved it by uploading the official firmware from QGroundControl and then I uploaded a custom firmware by selecting it from the latest beta releases as @dkemxr and @Yuri_Rage suggested.

1 Like