Servers by jDrones

Can't update MissionPlanner to beta on Linux

OS: Linux Mint 20.1
Mono JIT compiler version 6.12.0.122

I’ve went to Help screen and pressed the latest Beta version button, but it doesn’t work. A small window pops-up and something loads then it closes itself and never opens.
I’ve tried it several times but the version is remains 1.3.74.2.

I sometimes get errors like “Update Failed Too many open files”
and

Servers by jDrones