Can't Start Auto Mission Normally - Copter 3.4.6 - SOLVED

I have tried 3 different ways of taking off for an auto mission & only 1 of them works but not the way I would like:

1. Takeoff in Stabilize or Pos Hold mode & switch to Auto mode (partial success): Once in the air, switching to Auto makes the craft touch down to the ground rather quickly & then the craft takes off again to execute the mission. I would rather the mission just start from where the craft is instead of automatically landing first.

2. Arm in Stabilize Mode, switch to Auto & push “Takeoff” button in qgroundcontrol (fail). I would like this to work so I can execute missions with my phone alone. I read somewhere that one could fly without a radio & this seems to be the logical procedure. Instead, the craft takes off, hovers in place & does nothing else. I switch to Land mode to bring it down.

3. Arm in Stabilize Mode, switch to Auto & raise throttle stick on radio (fail). The craft kind of dances a bit on the ground until it finds a way to trip on the landing gear & flip over. It is very consistent with this behavior.

I’m hoping I am just missing something obvious. The log is only 1.97MB but when I upload, it says the file is too big.


Upload to Dropbox or google drive.

Only attempts 2 & 3 are in this log. I already know that it is a bit ass-heavy but that is because the battery is shifted aft. This will be fixed later.

Thanks for the help in advance! I still am learning how to read logs.


Well, the problem is solved. I don’t know the cause for the strange behavior but I upgraded to copter 3.5.3 & updated QGroundControl to the latest daily build & the mission flew as it should have.