Can't set path and control sub in simulation(ardusub QGroundControl)

Hello Ardu Community! I have to work width ardusub for submarin control, pixhawk 1 using.
For the first, I try to run simulation for sub controlling.
I build ArduSub as was writen in this article :
After installation, I run SITL as was described in here:
I downloaded QGroundControl from here:
After Sitl running, I run QGroundControl, and QGround connected with Sitl

After sitl running, I have in terminal:

Connect tcp: source_system=255
Loaded module console
Loaded module map
Log Directory:
Telemetry log: mav.tlog
Waiting for heartbeat from tcp:
(Like it runs manual flight mode)

And when I set point where to go in manual mode, it’s do nothing, just stayed in place. But I have message on top of my screen. See the screenshots below :

I don’t know, maybe I missed something? Can’t resolve this problem myself.

1 Like

I have the same issue, I did all the installation, the submarine is well floating, it’s well connected to QGC, but when I put velocity 0 1 0 nothing happens even after armed. Same for setspeed 1 it doesn’t change anything. The other modes than MANUAL aren’t suported as I read. I put tried circle it’s doing crazy moves. What a nightmare haha