Cant seem to get relay to work with rcn_option

Hey guys, i have a small issue here, with my f405std wing (flashed ardupilot v4.0) i have been trying to use the s5 for relay activation but i cant get it to work, according to my multimeter im always getting 5v at s5.

I have set on mission planner the following paramters
BRD_PWM_COUNT = 4 (to have only 4 PWMS, and the rest as gpios)
RELAY_PIN2 = 54 (GPIO 54 is the digital pin)
RC9_OPTION=34 (34 is the option that corresponds to map the relay pin 2)

i have tested my tarannis channel by setting the rc9_option to arm and disarm the plane and it works fine, but for a reason unbeknownst to me i cant get it to switch …

anyone has an idea?

On the messages screen of Mission Planner does it say RELAY 2 HI and RELAY 2 LOW (or MIDDLE) when you toggle the switch?

Nope, all i get is the following
12/18/2020 5:04:41 PM : RCOut: PWM:1-4
12/18/2020 5:04:41 PM : MatekF405-Win 0027003A 594B500C 2032345
12/18/2020 5:04:41 PM : ChibiOS: d4fce84e
12/18/2020 5:04:41 PM : ArduPlane V4.0.7 (f0d8ca5e)
12/18/2020 5:04:39 PM : RCOut: PWM:1-4
12/18/2020 5:04:39 PM : MatekF405-Win 0027003A 594B500C 2032345
12/18/2020 5:04:39 PM : ChibiOS: d4fce84e
12/18/2020 5:04:39 PM : ArduPlane V4.0.7 (f0d8ca5e)

even when i tried the “servo/relay” tab nothing happens

I tried this config on a Kakute F7 with Copter and it worked. Apples and Oranges I know. Can I see your parameter file? I could flash Plane to this FC it’s just on the Bench.

forum.param (20.6 KB)
Thanks mate, really appreciate the help

OK, so the Relay messages are only available in Plane 4.1.0-dev so ignore that. But with 4.0.7 Plane loaded on the Kakute F7 and configured as you have it (well RC8 instead of 9) the output on M5 (how the Kakute is labeled) switches between 0 and 3.3V as expected. I think it’s odd you have 5V on that pin. Could you try Output 7? I’m wondering if this is a timer issue. Chan 3&5 share the same timer on that board.

ok, let me give it a shot, i have r7 as lost plane option, But ill give it shot and report back. Give 10 minutes

Not the RC channel the output. Change Relay 2 to 56 and monitor that output.

Ohh sorry, i misread i was in a hurry.

Perfection!!! it worked flawlessly, although i dont have relay pin 56, only up to 55 as auxout, the others are bb blue, bbb etc. The point is that on relay pin 55 that corresponds to S6 worked flawlessly 0-3.2v

I really appreciate your help and guidance !!!

Great John, happy it’s working for you!!

One thing though, this is really weird, when i changed relay pin from 54 to 55 and connected a multimeter to s6 it worked like i said, but i then tried to put back relay pin to 54 and when i tried to write param, i got a “relay pin2 failed to execute write” something about those lines and mission planner crashed.
i restarted mp and tried again, i set relay pin on 54 and now it works, what the hell?..jejejje

well anyways thanks again for your time and guidance