Servers by jDrones

Cant move throttle with radio

(Karan Chaphekar) #1

Hi

I have a bit weird setup then usual. Its pixhawk with gps, but i have an old turnigy 9x hooked up to an arduino to do pwm-ppm. I got that part working
The platform is a car with servo steering. For driving motor which came with car i am using a smartflex driver. Its got a mode where it is compatible with brushed bipolar.
Both servo and DC motor moves in move motor section but not in failsafe ( only servo works) also i cant perform throttle tunning.
In failsafe mode i can see throttle change up and down with stick but servo 3 stays on 1500.
Please help solve this issue

Thanks
KC

(rmackay9) #2

@Karan_Chaphekar,

My guess is that the vehicle isn’t armed or a safety switch is enabled. If this is a pixhawk compatible flight controller then it may help to set the BRD_SAFETYENABLE parameter to zero.

Beyond this advice, it may help if a log file can be downloaded and posted somewhere like Dronee Plotter.

(Karan Chaphekar) #3

Ok . I am able to arm and make the motors move. But by using brushed bipolar and how my controller work i need to remove the connection till i arm it. Is there any way to send 1500 pulse by default even if its unarmed? I have switch on it which i use it to arm.

Now to next problem. I got a taranis so wiring is much easier now. Now even i manual mode i cant operate it like a nomral RC car. in arming only steering move. the throttle dosent respond in failsafe option either. I can run the motor using motor test. Thats how i know it works. But i am missing something. The pixhawk always show red led on top. I tried uploading px4 but for testing but it cannot detected my radio. but it did show me different status color.

I tried downloading log but it says
Getting list of log files…
No logs to download
I checked the sd card, formatted it many times but no success. might be red led is because of that.

(rmackay9) #4

@Karan_Chaphekar, it might be good to read more of the wiki and follow some of the advice in there.

It should output 1500pwm by default when disarmed. Please check the SERVOx_TRIM values.

A solid red LED when the vehicle seems to be working indicates a problem with the I2C connection to the GPS/compass unit. It might need to be replaced but it’s hard to say.

Logs can only be downloaded when the vehicle is disarmed. Logs are only created when the vehicle is armed. Make sure there’s an SD card in the flight controller - perhaps try formatting it.

(Karan Chaphekar) #5

Ok the problem was i didn’t arm it. I thought safety switch was itself arming.
Now next issue is it shows me cruise learning failed.
When i flip the switch it says cruise learning started and after second it says cruise learning failed. I tried to find log for this one but it was not recorded on sd card.
Car working find. throttle , turning. Getting 6 satellites on gps with 2.2 hcop. I though it said failed after i switched it back after second but it says just after enabling it.