Can't modify ARMING_CHECK parameter using Mission Planner

Missino Planner 1.3.74


I am following this guide: in order to use the MarvelMind beacons for indoor navigation and I can’t disable GPS arm checks.

I am having troubles modifying the ARMING_CHECK parameter. When I click on it a window pops up and I have to select and deselect whatever I need. I select everything except All, GPS lock and GPS Configuration and then I close the window. The value remains 1. I’ve managed to change it to 0 by deselecting All. I’ve then tried a lot of combinations but it never saves and it remains to 0.

I’ve managed to trick it however. I saved the parameter list as a file, I’ve modified ARMING_CHECK to -9 inside the file and then I’ve loaded the parameters into the Mission Planner and ARMING_CHECK is set to -9 now.

Is this the normal behavior ?

Also, I’ve checked and ARMING_CHECK -9 value disables GPS lock but leaves GPS Configuration enabled. Is that ok ?

Thank you.

All except the two GPS settings is 1043958
Maybe try updating MissionPlanner under Help, Check for BETA updates

I’d rather stay with the 1.3.74 Stable version.
Also, how do you know what digits correspond to what values for ARMING_CHECK ?

The guide says to set it to -9, but -9 disables GPS lock and leaves GPS Configuration enabled. Is that how it’s supposed to be ?

Simply check the boxes…

As I’ve said in my original post, that does not work. I check and uncheck whatever values and it does not remain saved.

I suppose because the version you insist on using is from:

But, suit yourself.

WTH ? But I’ve downloaded the latest stable version…

Right. Look at the Mission Planner Changelog which is where that snip came from. That’s what you are running. Run Stable if you want but sometimes a change is made daily, or more often than that, in Beta that fixes some problem.

Go to the Complete Parameter list, , check the param you are after and use the bit positions listed and a binary to decimal calculator to set the value
Arming Checks

Here’s everything except Hardware safety switch - a common adjustment
…and MissionPlanner gives the same result.

My first mistake was not to mention that I use Linux and Mono to start MissionPlanner.
I don’t know if I am stuck with this old version or not.

On the GitHub page it says: “Building Mission Planner on other systems isn’t support currently.”

Go to the Help screen and press the latest Beta version button. Assuming you have changed your mind and want to try Beta.

I’ve tried that. It doesn’t work. A small window pops-up and something loads then it closes itself and never opens.
I’ve tried it several times but the version is remains

I sometimes get errors like “Update Failed Too many open files”

Huh. Post over on the Ground Station>Mission Planner thread then.

yes, there’s a few things that dont quite work properly with MP on Linux.