Cant make all motors work

a total newbie here,

Yesterday I finished the assembly of my first drone based on navio2 and RP3+.
Although I was able to arm the drone, I got a message telling me Motors 2 and 4 do not run.

1.  All of the mandatory calibrations have been done on MP. 
2.  I checked all of the ESC-motor combos via connecting to only remote controller one by one. - All works fine  without problem.
3.  ESC calibrations done.

I changed the Frame type to see if any of the motors starts spinning.

  • If a different frametype than quad is chosen like octo,hexa —> 3 of the motors run. (3/4)
  • When the frametype is selected quad —> 2 of the motors run. (2/4)

I dont know why this happens, maybe reinstall the ardupilot? :man_shrugging: :man_shrugging:

Any help appreciated
Best regards,

Looking at the picture, I believe to see only two ESCs connected to the Navio. Is that the case?
And I see a very sharp bend in the GPS antenna cable. This is an HF cable, it might not work or even get damaged if bend to sharply.

1 Like

@count74 oh, the photo was taken when I connected my multimeter to measure amperes. Normally 4 of the escs are attached to the Navio.

I will be re wiring the GPS antenna cable as you adviced me, thanks for that!

Did you use motor test command in Mission Planner? Did you calibrate the ESCs?

@amilcarlucas yes I did calibrate the ESC. Moreover, lets assume the Motors 1,2,3 are working and 4 is not working. When I swap the motor pins 3 to 4, BAM- motor 4 starts to spin but motor 3 stops. So it is about the signal from the Navio.

yes I also tried to use motor test command in Mission Planner. It is the same, some motors run, some does not.

Yes, I just saw your post over at the emlid forum.
What happens if you configure outputs 5, 6, 7, 8 instead 1, 2, 3, 4?

I changed the configuration to 5,6,7,8 and nothing changed. Just on quad frametype no motors were spinning. But on the octo frame -again- 3 of them were spinning.
I could get the messages;

mp mesaj

mp messages log

Motors: unable to setup motor0, 2

Best Regards

Did you just plug the ESCs into 5-8 or did you change the servo output configuration, too?

1 Like

I did change the servor output configuration as follows too;
This is on half throttle, the non working motor is connected to number 6 (before restart).

Edit: When I restart the drone, MP.Everything all worked perfectly, thank you!