Cant maintain speed on autonomous mission

2024.param (18.9 KB)

I’ve been struggling with this issue for quite a while now and dont know what to do anymore.
I use Matek F405 wing v2;
Ardupilot/Mission Planner;
GPS TBS M10Q, no air speed sensor
Delta wing setup.

I created a simple autonomous mission and tested it in Simulator. It worked well, I also tested Do_Change_Speed function and it worked well. When I wanted to test it in the field the auto speed was not there. What I mean is that when i launch the model and switch to auto mode it starts to do the mission but i still control the speed with the throttle stick. I switch the auto mode switch when the model is the air and throttle is around mid or when the throttle is 0. I’ve tried various ways like setting gs/as(0 or 1), disabling throttle nudge, disabling airspeed_use and so on but every time i have to control the speed. There should be a simple solution to this as everything else seems to work. My GPS (TBS M10Q) seems to work fine and i dont have any other errors. I get ocasional errors about my compass but i calibrated it and it seems to work. I dont think its the compass issue as the GPS works fine. I also tried the autonomous “Shake it” launch but it didn’t work as well. I did everything step by step, even reset my FC to default settings and tried again but with no luck. I attach my .param file but couldn’t attach .waypoint file. The mission goes: TAKEOFF ->WAYPOINT->WAYPOINT->RTL.
Also when i connect FC to Mission Planer on the Data screen Actions tab it shows Change Speed (m/s). I think it should display Change Throttle because i don’t use Airspeed sensor. When i turn on the simulation it shows Change Throttle.

My actions sequence is this: I turn on the Tx then Rx, then connect FC to MP via USB and check if my mission is correct by Reading the mission in the Plan tab, then I Arm the plane, disconnect the USB and make a manual lift off in FBWA. When the plane is high enough I switch the Auto mode with the switch on my Tx. The plane starts moving to the first waypoint but I still control the speed with the throttle stick, the plane does not hold any speed.

Any help would be greatly appreciated as I dont know where to look anymore.
2024.param (18.9 KB)