Can't load remote telemetry settings

I need to be able to change my Net ID while in the field.

  • My telemetry radios connect fine through mission planner.
  • With MP disconnected and the Air Module turned off, pressing ‘Load Settings’ will populate the ‘Local’ settings.
  • With MP disconnected, and the Air Module is powered up, I cannot connect to the Ground Module using the 3DR Radio GUI. I get “Failed to Enter Command Mode” when pressing ‘Load Settings’.
  • Both Modules were SiK 1.7, then I pressed the ‘Upload Firmware (Local)’ button and changed the Ground Mod to 1.9. The modules still connect to each other via mission planner.

How can I load the ‘Remote’ radio’s settings?

Hi iskess,

If you are trying to connect the air telemetry, disconnect it from the autopilot and just connect by USB then try again.


I have the same problem and also I found the same solution suggested by RogelioN.
Nevertheless, I think that is a bug. I don`t know if that is a problem of Mission planner or is a problem of the radios.
I start to suffer it after update to sik 1.9

You mean I have to use an FTDI cable just to change the NetID? That isn’t very field friendly. What’s the point if the “Copy Settings” button.
Must be a bug. I tried MP 2.96 and 3.0. I tried SiK 1.7 and 1.9. I tried different radios and different computers.

Try this

That worked. I guess its a MP bug that has survived many versions, at least back to 2.96.


I’m glad to see it is working now.

If this is indeed a mission planner bug, please post it in mission planner board:

I was having the same problem after upgrading 5 radios to 1.9. This was very frustrating! Thank you for the fix.

iskess - are you noticing reduced range with your radios on the new firmware? I am using RFD900’s

I haven’t pushed any distance limits since upgrading to 1.9.
I sure hope it doesn’t lower my range! I’ll have to try. I use and RFD900 on the ground and a 3DR in the air.