Servers by jDrones

Can't Load ANY FirmWare Via ANY Method and Can't use Terminal

I am unable to upload ANY firmware to my copter. I’ve been trying for about a week now using both Mission Planner and QGround Control and pretty beyond frustrated. I need help.l

I’ve tried all combinations of the firmware settings, including selecting “copter,” “helicopter” “ignore”
“ignore” or “official”
“fmuv2” or “ignore”
“3.6.11” or “ignore”
“apj” or “ignore”
(selected my corrected com port ID) but also tried others just in case
“9” or “ignore” for board ID
“fmuv2” or “PX4 BL FMU v2”
and both firmware options, when two appear based on changing the above options.

It makes no difference. It took me almost two days to try all combinations, but I have.

I’ve also tried in QGround Control almost all possibilities, but did not try all different firmwares because there are about 50 of them listed. QGround Control gives the following errors:

“Error: Send Command” “Invalid Sync Response 0x53 0x75”

I was previously able to upgrade firmware using QGround Control. In fact, it’s what started the problem when I did a firmware upgrade, but did not realize the options were below. QGround Control shows my firmware as 3.6.11 but when I use Mission Planner to install Previous Firmware, I see all the upgrades from 3.6.11 and last upgrade shown on previous is “AC 3.6.7 AP 3.9.7” So I am pretty sure the QGround Control Update firmware thing I did caused this.
What is going on?

Mission Planner Firmware Error messages I’m getting:
“Scanning Com Ports” (pauses here for a long time then immediately:)
“Error: No response from Board”
(then popup window:)
“Error Uploading Firmware”

I’ve also tried using the terminal to connect but when I do, using any and ALL combinations of settings, I get:

“Can’t open serial port”

Did I brick my flight controller?

Using Pixhawk1 for 3dr x8 Octoquad.

Hi @vyoufinder,

  1. Are you able to connect normally to the board?

  2. What OS are you on? I’m guessing you’re using Windows, since you’re also using Mission Planner. Any chance you’re running it on a virtual machine?

  3. Do you have any other USB/serial devices connected when you’re attempting to flash the firmware? Also, can you check Device Manager for the available COM ports with the board connected?

  4. Have you tried a different USB cable?

  5. Have you tried using the “Force Bootloader” option in Mission Planner?

Arunabha42, Thanks for taking an interest in my post.

  1. Yes, I am able to connect normally to the board. I can connect, disconnect without problems.

  2. I am on Windows 10 Pro.

  3. Yes, I have a wireless internet adapter installed to one of my other USB ports. I am able to see which COM ports the wireless adapter and the Pixhawk are on (COM 1 & COM 5 respectively.) I also tried adjusting the baud rates to no avail.

  4. Yes, I’ve tried another USB cable. Both cables I tried work fine on my other Pixhawk board, so I’m pretty sure there’s no issue with the cable not being data capable.

  5. Yes, force bootloader works fine. It just loads the bootloader the same as if I just plug it in though. It’s not really clear to me what exactly force bootloader is doing, is it just booting the Pixhawk in cases where the bootloader failed initially?

Un-install mission Planner and install it again. The device drivers need to be reinstalled.

1 Like

Look at Pixhawk 1 memory limit

https://www.google.com/search?client=safari&rls=en&q=Pixhawk+1+memory+limit&spell=1&sa=X&ved=2ahUKEwiA-cC2jIXmAhVEyxoKHd67C0UQBSgAegQIDBAp&biw=1517&bih=924

Then this is what should work.

I tried that, didn’t work. But then I tried an old version of Mission Planner to load the firmware and it worked without a hitch. I think the version was 1.3.6 for anyone else unable to load firmware and having the same issue.

Servers by jDrones