Servers by jDrones

Can't get Pixhawk to go into AUTO?

After several issues with pre-arm failures on my sonar survey boat after a firmware update I still can’t change the mode from Manual to Auto - it forces itself into HOLD.

Any help will be much appreciated.

Made the following changes:
ARMING_CHECK = was 1 (All) changed to 72 (GPS lock only, no RC failsafe)
ARMING_REQUIRE = was 1 (THR_MIN) to 0 (Disabled)

Result:
LED = Solid Green (Armed GPS Lock)
Switch = Solid Green (Armed)
Mode = Manual (All works fine) Auto - still won’t go into AUTO forces into HOLD

can you please post the tlog?

I have read up on the following -
_"When and where tlogs are created: - _
Tlogs are recordings of the MAVLink telemetry messages sent between the APM/PX and the groundstation and are automatically created the moment you press the connect button on the mission planner. Files of the format YYYY-MM-DD hh-mm-ss.tlog appear in the “logs” subfolder in your Mission Planner installation folder or to the location you select in the Planner options [Config/Tuning] [Planner].

Besides the ”.tlog” files, ”.rlog” files are also created. These contain all the .tlog data plus additional debug output from the mission planner. but cannot be parsed or played back so they should be ignored."

I have found this /logs/ folder but it does not contain tlogs related to today’s date, only one rlog.

My head is spinning now.

John, Post your parameters. Wondering if a HDOP or Sat number failsafe maybe. You had it working good before so probably something simple I hope.

Regards,
David R. Boulanger

Thanks David,
I will certainly do that when I hook my laptop up to the boat a bit later today.

Hi Michael,
I went and had another look in that /logs/ folder and found it in a folder named /GROUND_ROVER/1/
2016-08-27 09-06-07.tlog (65.0 KB)

Jeez, you guys must think I have the brain of a sea cucumber! [embarrassed] :blush:

john, in that log did you attempt to arm?

I wanted see in the tlog an attempt to arm the rover.

Hi Michael,
This is where I am to date … (still no AUTO)
This is solid green LED, solid green switch (armed) and MANUAL Flight Mode

This is the same as above but changed to AUTO - but the mode simply changes to HOLD

Flight Mode Setup - AUTO

Flight Mode Setup - MANUAL

Here is the tlog I just did - 2016-08-28 16-42-35.tlog (382.8 KB)

It appears the images got a little mixed up, sorry.

Here are my latest parameters David …

fishtec_20160828_a.param (7.8 KB)

John, MIS_TOTAL is 0. Is this the value after saving mission waypoints? It should show the number of waypoints you have in your mission.

Regards,
David R. Boulanger

I just quickly looked at the Tlog and I see no waypoints on mission planner. AUTO will simply go to HOLD if there are no waypoints.

Regards,
David R. Boulanger

1 Like

PROBLEM SOLVED -
Thanks David, once again.

If you do a RESET DEFAULT SETTINGS, you must remember to re-load / write the mission to the Pixhawk otherwise there are no waypoints to go to.

Note:
I did suspect this some time back, so I created a little test mission, but I forgot one very important step - I forgot to ‘write’ it to the Pixhawk - Doink!

1 Like

It’s also not a bad idea after writing a mission to the Pixhawk to then read them back to mission planner to see that all is well.

Regards,
David R. Boulanger

1 Like

Hahaha, I wish I had read this post before heading to the lake today.

When it went into Auto it somehow had remembered my last mission (small test mission created at my home) and decided to shoot off in that direction and by the time I realised I was out of radio range. Took me the whole morning to locate a boat and go recover it.

New prop ruined, impeller filled with sand and seized, not sure about the motor itself.

Man is this some learning curve or what? :grin:

Sorry to read about this!! I try and reply knowing that you are about 7 hours ahead of me here in Florida. ALWAYS read the mission before switching to AUTO. Those of us who also fly things learn this very early on. At least you still have the boat. We that fly also are not that lucky!

Regards,
David R. Boulanger

1 Like

So true David, flying is so much more risky. I have lost 3 DJI Phantoms to date, that is very painful financially.

Also remember to “Restart Mission” after every mission completion if you intend to do the same mission. Otherwise it will stay in Hold after it completes.

I’ve never experienced that. Complete mission, change mode, back to AUTO and do it again.

Regards,
David R. Boulanger

Servers by jDrones