Can't get PixHawk/ArduPlane to make any DataFlash logs

I don’t have any DataFlash logs on my SD card according to Mission planner. LOG_BITMASK is set to zero. I set it to PX4/Pixhawk-default (65535) and write the parameters. When I power off the pixhawk and turn it back on and re-connect to mission planner, it is set back to zero.

I’ve only had my system for about a week, so still a beginner. Using mission planner 1.3.30 and ArduPlane V3.3.0.

I’ve tried setting the LOG_BITMASK in the Advanced Params list as well as in the Full param list.

When I go to Flight Data / DataflashLogs / Download Dataflash logs via MAVLINK, there are no logs listed. There’s a physical SD card in the pixhawk.

I removed the micro-SD card from the pixhawk and put it into my Windows 7 computer. Windows explorer says “The volume does not contain a recognized file system”

Have you tried to format the card on your computer? That may solve your problem. If not try another SD card.


No. I was afraid of making things worse. I’ll format it under Windows 7 - 64 bit. As Fat32?

Do they generally come formatted when purchased with the Pixhawk?

That was it. The micro-SD card from the factory was defective. I could not format it on two different computers. I inserted a 16 GB card and now I am making dataflash log files.

SD cards do go bad. I had one that was causing my Pixhawk to act up. As soon as I installed a new SD card everything worked. Apparently it automatically does what it needs to when you install a formatted card. They are just standard micro SD cards.


understood. Thanks.