Servers by jDrones

Cant flash back to 3.7 after 3.8


(edgar de rochequairie) #1

Hello ,

I just flashed AP 3.8 on my PH2.1 and found it is a lot glitchy in manual mode on the bench , the stick command doesnt respond well in other mode aswell .

I wanted to go back to 3.7.1 but it doesnt want to flash the firmware back , it is stuck on reconecting after i hit “OK”

It doesnt detect the board ,the board boot fine tho just doesnt go in flash mode :slight_smile:

ITs weird because i cant connect to it well in MP for settings but no flashing .

What can i do to remove the 3.8 fw

Thanks


(edgar de rochequairie) #2

IS there an emercency procedure to erase or reload a firmware ?


(tridge) #3

If you can connect then you can set the FORMAT_VERSION parameter to 0. That will reset the firmware to defaults on next boot.
If you can’t connect, then loading a different type of vehicle firmware (eg. Rover) will have the same effect


(James Davies) #4

I have the same problem. Pixhawk connects to MP and I can change parameters but cannot downgrade to 3.7. Tried the above two workarounds and they didn’t work. Is there another “emergency” method.??
I had my quadcopter working on 3.7. When I upgraded to 3.8 I could not get the quad motors to arm…that’s why I want to downgrade to 3.7 while I try to figure out why the quad motors don"t arm??
Any troubleshooting tips will be greatly appreciated.
cheers


(edgar de rochequairie) #5

I solved my servo jiterring problem with a Radio calibration , i stay on AP 3.8 and will test it ths evening :slight_smile: