Can't enable sonar in mission planner


I was just trying to setup a sonar on my APM 2.0 running ArduCopter v3.2.

I can hear the sonar clicking and I see some reasonable readings in the sonar menu in mission planner
But I just can’t enable it. I can’t change the checkbox state.

The release notes say the following:

[code]ArduCopter 3.2-rc12 10-Oct-2014
Changes from 3.2-rc11

  1. disable sonar on APM1 and TradHeli (APM1 & APM2) to allow code to fit [/code]

Could this be the reason why can’t enable it? Although i’m not using an APM1 or TradHeli.

Can you try these instructions? They should work. The MP sonar set-up page still needs to be updated to work with AC3.2. … ix-analog/

Hey, thanks for your reply. It seems to work now.

I have been having the same problem. I followed the instructions and I do seen numbers changing however not much change. I wish I could test it but the “terminal” tab apparently is no longer available to APM.


I also have the same problem. I have APM 2.5 with firmware 3.2 and Mission Planner version 1.3.17.
I setup the sonar according to the instructions on link … ix-analog/
However, I cannot enable it from Mission Planner’s Initial Setup-Optional Hardware-Sonar page. Also, when I try to connect APM from terminal screen I get strange messages. (Please see the picture.) Is that normal? Any further comments for this problem?

The CLI is no longer functional in ArduCopter v3.2 due to memory storage limitations.

I also have the same problem. I have APM 2.5 with firmware 3.2, and I did everything right, shows me distance properly, in Mission Planner, but no change in ALT HOLD, when I put hand or other object in front with Sonar. So, is [color=#FF0000]NOT WORKING[/color]…

TCIII: You may want to consider posting something on the site that the previously supported sonar won’t work on AC 3.2 due to issues. In the section(s) on sonar, your links take users to sonar suggestions/vendors. No mention that current AC won’t support sonar. $50 is a lot to pay only to find out in trouble-shooting that it won’t work/connect after all. Go look: … age/sonar/

Hi there!
I am having some problems connecting the MB1043 rangefinder to my PX4 controller, either directly or via a PX4Flow (optical flow), as the PX4 does not detect the sonar, so I always get 0 values for the sonarrange and sonarvoltage parameters .
The connection is made via the GPS1 port, as it appears that the I2C 2 port has a malfunction, and I can read the parameters provided by the PX4Flow, but not those of the sonar. Alsom I tried a lot of different combinations for the ports, but this is the only one that works for the Optical Flow.

In Mission Planner, I can’t directly activate either PX4Flow or the sonar (these options are grayed out) so I had to activate PX4Flow through the parameters tree. However, for sonar, I am unable to do so. I have already tried to change the various respective parameters, namely Addres and Type, but I cannot get the Flight Controller to detect the Sonar.

Can somebody help me?

Hi there, The Cube Orange didn’t exist when this thread you posted in was active. And of course it never ran on this Firmware version.