Can't connect to APM via Mavlink

Not sure what has changed but it had been working perfectly for a while. Now when I connect, there is appears to be a handshake but no data is transferred. I can see the connection work when testing via Initial Setup, but not in the main program. I tested the hardware configuration on a windows version of Mission Planner and everything worked perfectly.

Running RC5 on MacOSX 10.8.5

Here are my logs

[quote]I have exactly the same problem with the latest version 2.0.6. on an APM2.6.

I know my radios work as I can do it under windows and mission planner.

I can update firmware via USB but cannot connect to Mavlik via USB or 3DR radios.

Have reflashed firmware, etc, to see if that made a difference.

I can however get MP2 to connect via Mavlink PX4 using USB (have not tried radio link)

Guess issue like yours is related to the APM2.6 and earlier I tried also a APM2.0 and same issue.

Log file of the 2.6 is attached.


Same here.
Was running 2.0.0RC2 on both Win7 & 8.1. Upgraded to 2.0.6 and both machines told me that they thought the Mavlink baud rate was incorrect. Also had to install VC++ 2008 redist on win8.
However the USB connection was fine.
While having only the ‘latest’ version available to download might seem like a good idea, it does make downgrading quite difficult.
If it’s ok to post, I’ve got the 2.0.0 release in dropbox here: … 200RC2.exe
(I happened to have it in my downloads folder and reinstalling it enabled me to trim my copter today :slight_smile: )


Seeing the same thing here. Was able to connect without issue using version 2.0.0 of APM Planner on my Macbook Pro (OSX 10.9.2). Then I upgraded to APM Planner 2.0.6 and now can’t connect. I’m able to launch terminal and connect there, and I was able to upgrade the firmware. Looks like it’s making a connection, but doesn’t transfer any of the parameters or telematics via USB connection…

2.07 fixed my issue. Suspect others here will have the same result.

Thanks Bill!

Yep - v2.0.7 fixed the USB connect issue, thanks

Any reason why the Visual C 2008 redist is not included in the install package ?

You don’t need VC++ 200 Dist. We will remove that warning in future (only shows on 64bit installs)

The fix works for me as well. Thanks!

FWIW, I did get the VC++ 2008 Distributable warning on my 32-bit Win7 install of APM 2 (both betas and stable).

Just ignore that message. We will get it fixed soon, as its not something to be warned about