Can't connect my pixhawk 2.4.8 to my pc

My pixhawk 2.4.8 was working fine then everything changed. When i connect it through usb
the i/o led:
stable PW green
Stable B/E orange
Flashing Act blue
The switch led is flashing red
The main led closed
The pc isn’t reading the usb it’s not discovered and mission planner isn’t seeing it and it’s not in the device manger.
It was working fine but it stopped.

This is not a Pixhawk 2… it’s a pixhawk 1

It’s pixhawk 2.4.8. That’s what is written on it.

Hello @Osama_Hehsam,

Indeed, you have a Pixhawk 1 model. And this is the 2.4.8 version of this Pixhawk.

For your problem, when you plug your Pixhawk in your PC, you don’t see your USB ? Have you done anything (a flight, upload a firmware, etc.) before having this behavior ?

Yes i uploaded a firmware once then i tried to work with the telemetry module and from that it’s not working at all

Did you upload the Chibios version of the firmware?
If you did you may need to load new drivers for it.

Check in your device manager and you will find a USB device with a warning icon.
It will tell you ‘no driver’
I fixed this problem with a clean install of the latest Mission Planner.

I don’t see the usb on my pc port

No usb icon the pc can’t see the usb at all

If you have a Linux machine, try on it, I had a similar drivers issue with Windows.

I tried it on Linux nothing appears also. As if the pixhawk was hidden. No usb port appears when it’s connected. The laptop doesn’t even beep

I’m facing the same issue. What should I do?

It doesn’t show up in Windows Device Manager?

Yeah it does… And I can connect it via mavlink too…but it doesn’t beep and the main light is not on…its just like in the video posted… And when it comes to calibration it doesn’t detect the device…
I’ve tried resetting the pixhawk n formating the memorycard. Still it doesn’t beep. Then I tried switching from MP to QGC and qgc said the vehicle is not responding

Will QGC Flash the Ardupilot firmware?

I am facing the same problem, my computer does not see the pixhawk and the pixhawk is getting too hot, can you please write the solution

Good day,
just check you have installed the latest drivers and check also into the device manager if the system found the board

Which Pixhawk is this that is “getting hot”?

Hallettikten koçum ne sandın bizi :grin::grin:

Nasıl yaptın. Fmu ledleri yanmıyor. IO ledleri power sürekli. B/E sürekli ACI yanıp sönüyor. Ana LED beyaz .
Sivic takıp enerjisi verirken sivice basılı tutarsam. Yine aynı tek değişiklik B/E yanıp sönüyor ACI söndü.
Yardım lütfen