Can't connect MP on laptop via wifi to Speedybee F405-Wing

I’m trying to connect MP on my laptop to Speedybee F405-Wing via its build in wifi. Windows laptop is able to see and connect to the F405wing SSID. I’ve set SERIAL6_BAUD=115, OPTION=0, PROTOCOL=2 on the F405Wing. MP tries to connect via UDP 115200baud on port 14550 and get about 3/4 of the way, then shows this error “Getting Parm MAVFTP 1-1: @PARAM/param.pck?withdefaults=1.”

Any suggestion is greatly appreciated!

1 Like

I’ve had zero luck with the WiFi on the Speedybee F405 Wing also, mine just sits at “getting parameters” with no progress. No luck with BT using a mobile phone with QGC either. :frowning: What firmware are you on? Currently there seems to be:

I should add that I haven’t tried the Beta yet due to issues reported at SpeedyBee F405 Wing Firmware - #3 by RizHass making me want to wait for stable.

Edit: I’ve just noticed that I am seeing some telemetry data come through in the background so i think the settings aren’t wrong…

I am on Ardupilot 4.5.0dev. I also see some activity in background while connecting, so I am hoping it’s just some setting that wasn’t done correctly.

MavFTP can be switched off for testing … (BRD_OPTIONS bit 1). Then you can see how the individual parameters are loaded.

It’s working by Wifi but very slowly and it times out a lot. With Bluetooth it’s not working at all. Anybody knows the progress of this issue?

any luck on getting this working ?

I have uploaded V4.3.3 stable firmware, but cannot connect thru Wifi. How do I determine if the FC is transmitting wifi signal, because I don’t see any address popping up on the laptop?

Baud rate is set to 115, and serial6 is set to 2. FC is powered thru battery as well.

From the Status LED?

1 Like

Solved!!, I had to cycle thru the boot switch to get the FC to transimit

Manuals are sometimes useful.

BTW, when are we going to fix this document online? We should add INAV reference for F405 wing since both Matek and now SpeedyBee ship there FC with INAV.

If you use STM32CubeProgrammer or DFU-Util (for the bootloader) it doesn’t matter what that page shows.

1 Like

I’ve used iNav and betaflight configurators, and while I’ve had luck with both now and then I’ve hit boards that just don’t want to play nice. So I’ve started using STM32 more often and it’s been far more stable and reliable.

1 Like

Yes, exactly. Sometimes they work and sometimes they don’t. Sometimes they work and then a new version of the configurator will be released and then it won’t. DFU-Util to flash the bootloader and then Mission Planner to flash the firmware has worked every time for me. Or STM32.

Returning to OP’s topic: for what it’s worth, as of Rover 4.5.1, SpeedyBee F405 Wifi seems to works but in practice is unstable at least when connected to a Mac. It connects intermittently, it downloads some paramters but all of it takes ages and it disconnects and reconnects all the time; it’s so bad you never get a full parameter list and proper connectivity. I’m low-key suspecting it’s more of an issue with the F405 than with ArduPilot. Connecting over USB works fine.

(Edit: Putting the wireless module in Bluetooth SPP, macos connects but immediately disconnects, so that’s not an option either, it seems).

bluetooth mode is not compatible with ardupilot.

1 Like

I’ve been in touch with SpeedyBee. They confirmed issues with WiFi as follows:

It appears that the transmission distance for this model is relatively short, and it is recommended that you operate closer to the device for optimal performance.

My experiments suggest that ‘relatively short’ is a bit of an understatement.

They suggested upgrading to a newer model might be a solution:

[…] this issue has been significantly improved in the F405 Wing Mini model. If you are considering an upgrade or need more efficient performance at longer distances, the F405 Wing Mini may be a better choice.

Well then, full credit for the one that doesn’t work for one that does sounds good. 2 thumbs up for Speedybee…