Can't compile APM planner on Windows or install on Linux


I tried to compile APM planner on windows 7. I chose Option 1 (VS2010) and executed steps 1-9. Step 4 worries me because I have to add the bin folder of msysgit into the path, needed for touch. There is no bin directory so there is no touch. I have several lying around and I put cygwin\bin in the path as it contains touch.exe. But I am not sure what other programs are expected to reside msysgit\bin.
When I compile I get the error message:
‘cl’ is not recognized as an internal or external command,
operable program or batch file.
jom: E:\repository\apm_planner\Makefile.Debug [build-debug\obj\QsLog.obj] Error 1

And the build process seems to stop. Just don’t know what this means.
[Edit] I kind of forgot to select the MingW compiler, as the readme suggestred. That seems not to be the error, the compiler selected is the MSVC 2010 compiler with SP1 added.

As a test I tried to compile on Linux, Debian, 64bit. There I have troubles with the step:
sudo apt-get install git qt5-qmake qt5-default
qtscript5-dev libqt5webkit5-dev libqt5serialport5-dev
libqt5svg5-dev libsdl1.2-dev libsndfile-dev
flite1-dev libssl-dev libudev-dev

qt5-make and other qt5 libraries do not exist. I tried to find out with synaptic and noticed that only libmgl-qt5 exists. The other qt5 libraries do not exist.

What exactly am I doing wrong??

Thanks in advance for any helpful answer.



The error about not being able to find cl.exe means it is not pointed at the right compiler (MSVC), or your MSVC install isn’t complete/correct. Start up a test project (one of the QtCreator example projects) and get that compiling first to ensure QtCreator is configured properly.

I mentioned this on github, but it is worth repeating here: AP2 requires Qt5. We support Ubuntu 14.04LTS, since it comes with Qt 5.2.1. To get Qt5 on Debian stable, you need to enable the testing repositories, as detailed here:
All the appropriate warnings about Debian Testing being unstable apply.

Hi Malcolm,

Thanks for your answer! I’ll start figuring out what’s wrong with my MSVC install. That’ll take some time.

I have read some articles about the Debian including the link you sent me. As a result I decided to create an Ubuntu machine and test on that. I had the mistaken notion that installing on Debian, being the parent of Ubuntu, would be as easy as on Ubuntu :slight_smile: