Can't change flight modes with Futaba T8J

I am brand new to the APM world, so I may be overlooking something however I cannot manage switch flight modes. I am using a Futaba T8J with an R2008SB receiver, my apm is running arducopter v3.2.1. Whilst in rx calibration, my channels 1-4 work perfectly but my channel 5 switch doesn’t register on the apm. I’ve tried channels 5 and 8(input)- neither of them have worked. Both were set up on a 3 pos switch and when I changed the position none of the pwm values moved. To test that it wasn’t the apm, I attached my throttle channel to the input 5 which then allowed me to change flight modes. Switched back to 3 pos switch…nothing. Everything has been calibrated as well- except for ESC’s if that matters. I’m really at a loss guys, any help would be greatly appreciated.

Use a spare analog servo to verify that all output channels on your RX function.
If the T8J TX radio is set up incorrectly it is possible that the receiver is only “seeing” the first four channels.
I believe that the R2008SB receiver will output a neutral signal for any channels ‘missing’ from the TX radio signal.
You should be able to verify your transmitter switch setup using the servo display menu on the T8J.