Can't change Flight Modes from the Tx

Hi All,

My setup is APM 2.5, Arduplane 3.30 fw, Mission Planner 1.3.26 build 1.1.5618.37515.

I can’t change APM flight modes with the Tx switch.

I can highlight any Flight Mode at will in Mission Planner’s Flight Modes screen by changing the Flight Mode switch on the Tx. I have mapped the desired flight modes for each PWM range, i.e, “RTL” for Mode1, “Auto” for Mode 2, etc, by choosing the appropriate modes from the drop down menus and have saved the modes by clicking on the “Save Modes” button on this screen.

The “Current PWM:” field in this screen is showing PWM values coming from the Rx within the range expected for each flight mode. However, in this same screen the "Current Mode: " message does not change to reflect the current mode highlighted in green, and the flight mode does not change in the Flight Data screen, remaining fixed in whatever mode was set in the mode menu in the Flight Data screen “Actions” tab.

I surely must be forgetting something, as I have done this successfully before. Can anyone please help?


I’m having a very similar problem… But I dont even get the boxes to high light on the flight modes screen when I move the switch. The channel is moving in the radio calibration screen and the ppm values look ok.

I’m using a Taranis and have tried two different recivers…

Any ideas…

Sorry about the high jack.

Setting up flight modes in the radio correctly was the hardest part of switching to Pixhawk
Here’s a link I used with my Futaba. Once you get it done, you’ll never have to do it again…

No worries about “hyjacking”, droneserve, I hope the problem gets sorted on your end. Watch the video posted by JoeBob (thanks Joe).

In my case, I was also using a Taranis. The boxes would highlight in green as I said, just like the 5:00 mark in the video but with no mode switching. Then I swapped the radio for a Spektrum 7. Same thing. Then to make things really interesting, I tried another APM board. Bingo! Worked with both the Spektrum and Taranis. Curiously both APM boards have the same, 3.30 firmware - one responds to flight mode changes, the other doesn’t. Very strange… looks like one of the APMs went south. At least it was on the bench, not flying a route 300ft in the air.

Have you tried installing the copter firmware and then reinstalling plane 3.3.0? It should wipe out the settings and give you a fresh install to start from.

Thanks for chiming in, Mark,

Yes, but that didn’t help. It may be time for a Pixhawk… :wink:

it could be you don’t have gps lock, or a list of other things. some modes wont engage unless it is safe to do so.

try a fill param reset as well, could be a bogus setting