Servers by jDrones

Cant boot PX4MiniAIO v1.3 w/3.5.0-rc7


(Fernando Cunha) #1

Hello,

I’ve tried to upgrade a quad from 3.4.6 to 3.5.0-rc7 but i could not make the board boot. After the upgrade, it keeps repeating the sound “New IO board firmware loaded successfully”. If I revert the firmware it boots OK. I tried to load the correct binary for ardupilot-v1 but it gave the same error.

Is the new code supposed to work on this board? If not, is there any plans to make it work? I´m just asking because I need to know if I will need to replace the px4 controller…

Thanks ! Fernando


(Francisco Ferreira) #2

Hi Fernando,

As with all clones, it is always possible that we break something as many times they don’t even properly copy the spec. We do try that firmware works with the clone hardware people have and buy as best as is possible. I think we’ll need more from you though. Does it keep rebooting giving the sound? Or it only does the sound again after you reboot it? Have you tried connecting through USB and see if there is any error message?


(Fernando Cunha) #3

Hello Francisco,
Thanks for helping.
This board is known to be problematic: Airbot-PX4MiniAIO-v1-3 The only reason I´m still using it is that I´m lazy to take this little drone apart to replace with another px4 ( which i already own ). It keeps doing the sound after the initialization. I will do a small video and post to help. No messages through usb. It is a Px4V1 board.


(rmackay9) #4

I wonder if this could be resolved by attaching a safety switch and then holding that button down as the board boots up (a one time operation). We discussed this problem that some have bumped into… the need to force the upgrade of the I/O firmware. I think the issue is actually in AC3.4.6 meaning we might need to release AC3.4.7 with a patch to ease the upgrade process.


(Fernando Cunha) #5

Thanks, tried that without success. Should I go down to ac3.4.6 and press the button ( will try that ). If you could briefly guide me I will appreciate!

Best Regards, Fernando


(Fernando Cunha) #6

Thanks Randy,

Kept pressing the swich right after the 3.5rc11 firmware program and it has worked!


(rmackay9) #7

@Fernando,
OK, great. I’ll include that in the release instructions.
I’m actually planning to push out AC3.5.0 today.