Can't bind a DSMX satellite receiver to Pixhawk 4

Hi All,

I’ve just bought a pixhawk 4 board and I can’t get a dsmx satellite receiver to bind with my transmitter.

I’ve tried all three options in the spektrum bind option in QGroundControl but each time the status led on the GPS module flashes green, there’s three quick beeps and then nothing.

I’ve tried using another satellite receiver that had already been bound using it’s master receiver but that didn’t work either.

Two things I’m wondering about: 1. I’ve only just unboxed the pixhawk and I’m powering it off it’s USB connection so maybe there’s not enough power and 2. The receivers and transmitter are probably around 7-8 years old.

Transmitter: Spektrum DX8. Tried using 11ms and 22ms frame rate as well as an additional Spectrum DX7.
Receivers: Two satellite receivers from two Spektrum AR8000 receiver kits. One was bound, one never been used.
Pixhawk 4 board: 1.7.3dev set to generic ground vehicle (I’m building a rover).
QGround Control v3.3.2

Any thoughts or suggestions gratefully received.


I copied this from my DX7S manual. It is the procedure I used to bind the satellite before hooking it up to the Pixhawk 4. I plugged the satellite into the AR8000 to bind as indicated.

Hi Bisenberger,

Thanks for the response. I posted this question on a lot of forums and obviously forgot to update this one. It turned out the pixhawk to receiver cable supplied with pixhawk had been incorrectly wired. I swapped two wires over and it works well now.

Thanks again.

Hi Dave,
Glad you got it worked out.