Can't arm motors

I am using ardupilot 3.2.1 on a quadcopter (X config) and it has been working fine until I had a crash recently, there are no visible signs of damage to the ardupilot and the quad only required a motor shaft and 2 new props but I can’t get the motors to arm now.
I have tried a full reset by installing a different firmware then reinstall original firmware (as the terminal window just constantly produced gibberish) and been through all the settings but still not getting any motors.
I did notice in the messages tab in flight data that there are lots of lines in red, mostly saying [MAV 001:1] PreArm: Bad Velocity and there were also some saying [MAV 001:1] PreArm: High GPS HDOP or [MAV 001:1] PreArm: GPS glitch but I haven’t found anything useful in searches for explanations of these. APMplanner2 was showing that the APM had a 3D GPS fix at the time.
Any help would be very welcome.

Please provide tlog and/or dataflash logs to help troubleshoot your issue.

I’ve got a bit stuck on that one, did a search for where to find the logs and got to this page: … n-planner/
but I don’t have the ‘dataflash logs’ button on my version of APMplanner as is shown on the web page and I can’t find a menu option for it.

Further to previous, I found the data folders on my PC, the dataflashlogs folder is empty but there are 4 files totalling 5 MB in the tlogs folder, there is also a logs.txt file in the data folder, which of them do I attach, our internet connection isn’t very good so it could take quite a long time if all of them are required.

Try using MP. The dataflash log download button is right below the HUD.

Afraid I don’t know what ‘MP’ is.
Don’t see the buttons, I have attached a screen shot of what I get.

MP is “Mission Planner” and you are running APM Planner. Can you download mission planner? That will allow you to get the logs.

Thanks for that.
It is showing 13 logs all dated 01/01/1970 00:00:00 so I downloaded 13 and it put 5 files on my PC, I have just attached the .log file, please let me know if more are needed.

It seems to be fixed, I ran the setup wizard in mission planner and the motors armed after.
Does it do something differently to APM planner during setup, as I had been through that a few times.