Cannot Upgrade firmware, Unable to open COM port: usbmodem14

OK, first, I have tried searching the forum, and have not found anything that solves the problem. As background, APM 2.6, 3DR Y6 kit, Macbook AIR with OSX 10.10.4, APM 2.0.18. I can connect via USBMODEM and read the parameters, but when I disconnect, switch to Install Firmware (for 3.2), I get this:

Started downloading … Copter.hex
Finished downloading /var/folders/rg/5qqx9ls91xldgkv2qd1r_4880000gn/T/APM Planner.YZC506
Opening firmware file…
Hex file loaded: 244056 bytes
Unable to open COM port: usbmodem1411

So the USB com port works except for firmware. I have had the copter going on two years. As APM has been updated, I often have problems connecting via USB cable after an APM upgrade, and have started dropping and re-adding the USB Link, and that would, in the past, solve regular connectivity. I can also connect via telemetry. Only NOT for firmware upload.



The posts from the forum I have tried were to use the FTDI Drivers Installation guide for MAC OS X and disable IOUSBFTDI.kext; that didn’t help so I reverted back. There was another post to removed the “modemmanager”, however the Unix commands were not valid commands on my MAC, thus I could not see if that would help.

As a retired IT guy, it just seems as though the method to open the port for a firmware load is different than the method to read or write parms to the APM, as clearly I can read and communicate with the APM through the USB connection, except for Install Firmware.

I’ll test this today to see if anything is broken. The APM uses the arduino driver. Try updating Arduino IDE to install new drivers, or remove the ones installed.

I do not see that the Arduino driver is loaded on my Mac, that it invokes the FTDI driver.

I have been trying to use the APM Planner, but out of curiosity, I re-booted under Bootcamp to Windows, and the firmware install worked fine doing that. I am hoping to leave it behind so I can remove that from disk, but I guess I will keep Windows on my Mac for a while longer.



Try this version as it fixes the issue … 015-08-04/

It was a problem with the underlying Qt framework with serial ports, the framework was updated in 2.0.18 release.

Thanks as that fixed it!