Cannot Upgrade Firmware or Get Params

I’ve received a couple of new Orange Cubes and I went to change the firmware (they had ArduPlane on them initially but I needed ArduCopter) but I’m having a lot of issues. I’ve had many boards before and this is the first time I’m having this issue.

First problem is when I try to do this on Mission Planner, it says ‘Failed to discover board id’.
A few notes/comments regarding things I’ve checked:

  • The initial ArduPlane did connect properly
  • The COM port has the proper driver and does show Cube Orange Mavlink
  • I tried on QGroundControl and it does connect and did change the firmware but that leads me to my next problem

Second problem is that now that I’ve updated the firmware on QGroundControl, I cannot seem to connect to Mission Planner. It’ll connect like normal but then gets stuck on ‘Getting Params’ for a never ending amount of time. This is a wired USB connection and the wire itself does work. Note that it does still connect in QGroundControl but I want to use Mission Planner as that is what I am used to.

Does anyone have any advice or experience with this problem? Thank you

I had this kind of trouble many years ago.

I think I solved it by using bootloader update tool from Mission Planner.

I’ve tried this but no luck. If I do the bootloader update from Mission Planner, it doesn’t work and gives an error. If I do it on QGC, it does work but nothing changes once I go back to Mission Planner.

The error is: