Servers by jDrones

Cannot update MP -- remote server returned an error


(Frankie Fung) #1

The MP version on my Windows 7 laptop (32-bit, not 64-bit) is not update, at 1.3.40 build 1.1.6105.13696. After updating, I got an error message,attached, saying Remote Server returned an error.

Before updating, I have the laptop Windows 7 updated at Microsoft website.

Anything I can do to have it updated ?

Thanks!
update%20error%20message|690x387


(Michael Oborne) #2

please reinstall from MSI, this should resolve all your issues.
http://firmware.ardupilot.org/Tools/MissionPlanner/MissionPlanner-latest.msi


(Frankie Fung) #3

Thanks Michael. I solved the issue by reinstalling from msi.

Being the main developer of MP, you should be the best person to help me with the other questions on this software :–

  1. I accidentally checked the LOG_BITMASK box under “Fav” column in Full Param list… As a result, this param moved to the top of the param list. How can I move it down so it is listed in alphabetical order ?

  2. I have 3 laptops with latest MP version (1.3.61) installed. However, I got “Payload Control” tab underneath HUD in only 2 of my 3 laptops, but missing it in the 3rd one. I tried re-install both .net framework 4.6.1 and msi, and reboot the 3rd laptop. But this did not help.

The 2 laptops with “Payload Control” appearing are :

a) Toshiba Satellite running on Windows 7 (32-bit OS)

b) Acer running on Windows 10 (64-bit OS)

The laptop without “Payload Control” appearing is HP running Windows 7 (64-bit OS). During re-installing msi, I was prompted to choose “repair” in the installation setting.

Any light you can shed to troubleshoot ?

By the way, I searched “Payload Control” in MP serach box with nothing returned. Any description on this ?

Really appreciate your help.

Frankie


(Michael Oborne) #4
  1. untick fav, and it will go back into the list as normal
  2. right click the menu, pick customize, and add back payload control

(Frankie Fung) #5

Thanks. I got the payload control tab back.

But for moving the param, I tried unchecking the fav before, there was no change.

Just now, I tried again unchecking the fav, there is no change in the screen. I then click “disconnect” and “Connect” again, not only the param still stays at the top, the check mark re-appears. Weird.