Servers by jDrones

Cannot type into nsh shell to reboot Pixhawk


(Chinedu Amadi) #1

Hello everyone, so I am able to connect to the system console via the FTDI cable. I got a hardfault after
my previous flight and when this usually happens, I connect the FTDI cable to the serial on the Pixhawk in
order to reboot or “flash” it back to normal.

But for some reason I am not able to type into the terminal to reboot the board. I have uninstalled and reinstalled screen but that does not fix the issue. Additionally, the nsh> line does not come up after connecting the Pixhawk to the FTDI cable, I do not why that is. I also tried using a different terminal application, terminator, but the issue still persists. I have included a screen shot of terminal page.

Any assistance or suggestions will be greatly appreciated. Thank you.

hard

In the image above, I am unable to type B to continue rebooting. I have tried copying and pasting B but to no avail.

PS, the reset button on the Pixhawk does nothing as well.

PPS, I tried following the discussion on this page Arducopter\Pixhawk hardfault on bootup (custom firmware) to use the px_uploader.py but I was not successful. I typed this into the terminal:

I would greatly appreciate any assistance. This issue has been troubling me for days. I also connected the FTDI cable to a working Pixhawk but it still did not output the nutshell input line. Could it be the cable? Anyways, thank you in advance for your help.

Regards,
Chinedu


(James Pattison) #2

It’s difficult for me to know specifically what you’ve done (not many PX4 users on this forum), but I’d suggest replacing the bootloader and going from there.
There are a few bootloader options, and methods to flash them. If you’re looking to use ArduPilot I’d suggest using our bootloader, but the older one works fine.


(Chinedu Amadi) #3

Thank you for your reply James. I will look into other bootloaders.