Servers by jDrones

Cannot run on Mac OS


(govsux) #1

Has anybody else with a Mac had issue running QGC? It used to work. I’m running Mac OC 10.10. After a QGC update about a year ago it would no longer launch. I figured it would iron itself out in the next update but even after a new install today with the latest version it’s the same problem. I do have 3rd party apps okay to run checked. It starts to launch for maybe 1 second then quits. I don’t see others posting about this issue so I assume it’s on my end but if anybody has any idea’s I’d really appreciate it. I even tried to log in as a guest user but still have the same issue.


(DonLakeFlyer) #2

If I remember there has been one report of QGC not running on older OSX versions but that just one. Whereas no reports of any problems like that on current OSX versions.


(Mike Boland) #3

I can confirm QGC 3.4.2 crashes on startup
MacBook Air OS X 10.6.8
It tries to run in 64 bit native on a 32 bit machine.
The current download does state 10.8 or higher so a crash isn’t unexpected.
There is also a display difference on the MacBook Air that trips up quite a few programs.
It runs fine under 10.14.


(DonLakeFlyer) #4

QGC will only run on 64 bit OSX versions.


(govsux) #5

Running this in Terminal says 10.10 is 64 bit [ getconf LONG_BIT ] so I’m still at a loss :[ I’d update to 10.14 but there are other things I run would no longer work and Apple ruined iPhoto after 10.10.