Cannot rollback to Copter 3.5.7

I want to go back to Copter 3.5.7 after having a couple of issues with the latest firmware (3.6.1) However, when i choose 3.5.7 from the previous firmware options Mission Planner is unable to download it. It throws up errors about url problems. See attached screen grab. Any idea what is causing this, and how i can get around it. Thanks.

Same for me , i need help…in my case , i have “cant detect your board version,check your cabling”

What version of Mission Planner are you using?

Thanks Fred,
I am using version 1.3.59, build 1.3.687035631. I updated a couple of weeks ago i recall.


Have you tried the force bootloader option?

You can use QGround control to roll back to a previous version

Thanks again, Fred
I tried QGround Control, unfortunately that does not give me the 3.5.7 firmware option, cannot find an option for picking previous versions. Have also tried forcing bootloader in Mission Planner, that also failed.
I have even rolled Mission Planner back to 1.3.58, still the same issue.

Does anyone have a link to Copter 3.5.7 that i can download directly? Then i could install it via ‘Custom Firmware’.

I searched through Mission Planners history and logs and copied the url of where it originally downloaded 3.5.7 from, but that link is now dead, just a 404 error.



IIRC, there was a problem with MP downloading older versions. Please try to install MP latest beta version, as I think it was resolved in it.

Thanks, Igor,
Tried that suggestion, but the latest beta version i could download was older than my current version, but i tried it anyway, with the beta version the newest firmware i had the option of downloading was 3.5.4, so no luck with that suggestion.

Out of interest i went back to the latest version of Mission Planner (still not downloading 3.5.7) and tried to download and install 3.5.5. No problem at all doing that, the problem only seems to be when i choose 3.5.7 Very annoying because 3.5.7 was a really stable build on my hexa.

Is there anyway i can tell if it’s the url for 3.5.7 that is the fault - has it been removed from the server?

Any more ideas would be welcome,

Thanks again.

I just found some info about MP not being able to download 3.5.7. It seems to be resolved in the latest MP beta, so you should try again with it.

Hi, I do not want to have the same problem, fellow Steve
Does anyone know where I can download firmware Copter V3.5.7 from controller Pixhawk4?

I have searched Firmware site, path: / Copter / stable / Pixhawk4 and I can not find it

I like to have them local

Thank you

Hi Igor,

I have checked again the latest beta, i can only see one dated March 2018 - i am looking in the Beta folder on the main Mission Planner download page - do you know where can i find the latest beta?


Hello again, Igor,

Thank you! This time i updated Mission Planner to a beta version from within Mission Planner itself - (Help - Check for Beta Updates). This way i was able to update Mission Planner to the latest beta release -
I am now able to rollback to firmware version 3.5.7 without problem

So thank you once again for your help in solving this for me, very much appreciated.

Hopefully this thread will help others having the same issue.

1 Like

Thanks Steve i have been trying to go back to ver 3.5.7 and had the same problem till i followed your instruction.
First attempt i didn’t have my sd card in and it didn’t seem to work.(could not connect to MP).
Put sd card in and now loaded and working.

Tried the recommended solution above using MP 1.3.59. I can see AC 3.5.7 as an option but it will not load. Why was this option removed from the latest MP version? I tried AC 3.6.8 but am having issues and would like to roll back to 3.5.7 for comparison. Any ideas?

Never mind, I figured it out. Sorry to bother everyone.

Hello everybody! Is it possible to backup current firmware before update? I really want to have some ways to rollback, as current version seems to be quite good