Cannot get SkyViper V2450GPS to do anything! Factory Reset Fails

Hi Everyone,

I purchased a Sky Viper V2450GPS as a gift online and it seems to be bricked. I am decent at tech stuff so I figured I would be able to get it working but I am completely stumped.

My problem seems very similar to the one posted here:
https://discuss.ardupilot.org/t/factory-reset-not-working/24595/10

The controller (TX) can connect to the drone and I can connect via WIFI, but when I go to 192.168.99.1, none of the parameters are exposed or responsive, except for the live video stream. I can also Take Pictures and Toggle Recording from the web interface and it stores them correctly on the installed SD Card.

However, my Flight Firmware is shown as “unknown unknown” and my Transmitter firmware is shown as “unknown”

  1. I tried placing the latest firmware and renaming it as flight_fw.abin and that did not work.
  2. I tried uploading the firmware through the web interface and that did not work.
  3. I tried placing “FACRESET.TXT” in the root of the SD Card and that did not work.

I’m thinking the previous owner may have screwed up the Baud Rate settings trying to connect it to GPS software, but this is where my skills start to dissipate.

I tried to PuTTY into the 2017 port and I didn’t know what the commands would be to reset the Baud Rate. I did however, try to update the firmware from the web interface and I got the following, never ending loop of errors output to the PuTTy terminal:

dev> file_upload: uploadtype=ArduPilot filename=flight_fw.abin size=1148439
ardupilot_upgrade: size=1148439
checking firmware MD5
MD5: 01cb6568d509d939f016f69ab143f5f7
Good MD5 on fc fw image
Good MD5 on image - starting upgrade
Attempting to get telemetry control
serial switching drained 0 bytes
Sending mavlink reboot
Setting local baud to 115200
Sending mavlink reboot
Setting local baud to 625000
Setting local baud to 416000
Setting local baud to 312000
Setting local baud to 250000
Setting local baud to 208000
Set ting local baud to 115200
Getting bootloader sync
Failed to recv sync
Still awaiting sync (0/10) (0 bytes drained)
Failed to recv sync
Still awaitingsync (1/10) (0 bytes drained)
Failed to recv sync
Still awaiting sync (2/10) (0 bytes drained)
Failed to recv sync
Still awaiting sync (3/10) (0 bytes drained)
Failed to recv sync
Still awaiting sync (4/10) (0 bytes drained)

After 4/10 it would just continue a “Failed to recv sync” message over and over and over.

Can anyone please help point me in the right direction here? I actually bought this as a gift for a friend and his birthday is July 10th, I am running out of time trying to get this to work!

Thanks in advance for any help.

-Mike

That sounds not-good, frankly.

Are there any lights on the drone?

If any of the red or green lights are on I’d be guessing a loose
connection between the Sonix and stm32 boards.

Hi Peter,

When I first plug in the battery, the red and green lights on the drone turn on, but quickly fade out. They don’t stay lit.

The light that seems to be ‘inside’ the drone flashes for about 2-3 seconds then turns off.

I think this is a classic case of the Sonix board cable being disconnected from the Flight board.

I suggest checking that out.

The Sonix is the WiFi board so it makes sense since the WebApp can’t seem to communicate to the Flight board. I bet if you went to the “Messages” tab on APWeb syste status page it’d have some messages like that.

Oops, didn’t read @peterbarker’s entire post, he already said that…still that sounds more logical. And I provided pictures :wink:

Easy to disassemble. Take off the battery holder with screws. A few more screws and the bottom casing comes off. You shouldn’t have to mess with anything else, as the Sonix will be right there. Just make sure the cable is snug and plug the battery back in…see if it starts working. If the Tx is connecting AND your Wifi is connecting, then it is safe to assume both boards are working correctly…they just aren’t working together.

2 Likes

@lordneeko

Thanks for the detailed response! I’ll definitely check this out. I recall the few times I checked the messages log the was actually nothing there, no messages at all (in the web application).

Unfortunately, I’m away for the weekend so I won’t be able to tackle this right away, but I’ll get to it as soon as I can and let you know how it goes.

The pictures help a lot, thanks again!

1 Like

My experience (since you referenced my similar issue) was that the telnet session would eventually resolve that long running script that seems endless, and allow for console input (like poke-testing to find the baud rate). Once you diagnose your physical board connections, try telnet again, or maybe the baud is fine and it was just the board being disconnected and you’re hopefully good to go. Fingers crossed for you, dude.

The issue I had with the PuTTy telnet session is that I had no idea what the commands were. I couldn’t figure out how to check or set the baud rate, see what serial channel was set, etc. It was just a black screen. I did some investigating for the correct info but couldn’t find much, and it was getting late.

How did you eventually actually set the baud to 57600 using Telnet?

You will be able to type “help” to list all commands available to you. You will want to type “baudrate” then the integer value you want to set (57600, or maybe something else…that value was proprietary to my circumstance because of my own snafu, but I had set it for a reason). Assuming that there wasn’t just a physical connection problem and the baud rate is maybe fine.

@Orffyreus

That’s interesting, I actually figured you literally meant ‘help’ in your post, but it didn’t work for me.

For what it’s worth I’m using PuTTy as my telnet session client. When I connect and type “help” it just says unknown command. Same with many other things I tried (baudrate, serial1_baudrate, etc.). Could it be the fact I’m using PuTTy and not the suggested client? (Suggested client was blocked by my antivirus and I assumed it shouldn’t matter).

Either way I’ll try to get the drone before I leave and check it out in my downtime before Sunday.

Thanks again, I’ll keep ya posted.

I used PuTTy and it worked fine. The issue with PuTTy is it doesn’t handle the line breaks like netcat does so the text is all over the place, but the commands still work.

Ensure you’re connected to the SV’s Access point, the telnet to 192.168.99.1 on port 2017 using TCP…it should just work.

netcat is typically flagged by antivirus because hackers like to embed it in other things (like JPGs or word documents) and use it to initiate a reverse shell. so AV automatically flag it.

Again, I still think your issues are disconnected cable.
good luck!

Huh, that’s weird. You should literally be able to type “help” to list out
all commands (I tested it myself before posting that, just to verify that
it was “help” and not “?” or something else…it’s definitely “help”).

For telnet, I am using JuiceSSH from my Android phone. PuTTY should work
fine, tho; I’ve used it in the past for other purposes without issue, but
not for anything drone related (simply out of circumstance: I use my phone
for droning, and I’d already downloaded the JuiceSSH app when I was putting
together a network diagnostic tools folder for general WiFi
troubleshooting).

1 Like

@Orffyreus, @lordneeko, @peterbarker

I took the done apart today and the connections seem fine? In fact, when I remove the connection from the sonix board, the wifi access point SSID isn’t even broadcast, likely because at that point there is no power to the sonix board which has the wifi.

I plugged the cable back in and powered it back up and everything is back to my original problem. I see the are four connectors, could a single wire cause this?

I did notice that the metal case of the sonix board is really hot when the battery is connected, is that normal?

I did download juice ssh and was able to properly connect to the telnet session and get all the commands and whatnot from my phone (don’t have computer), but I don’t really know how to troubleshoot through that session. When I checked mavlink status it did say zero sent and received at 625000.

See attached file

1 Like

Yes the Sonix board does get hot when it has power. Yes a single wire can cause this. I had it not getting a reading from the magnetometer. Someone told me to reconnect the GPS board. I looked at the connector and two of the female pins had slide backwards just enough to break contact. Once I fixed the bent lock tabs and reassembled it started working fine.

1 Like

I really can’t see anything to suggest the connection is bad.

I mentioned in the original post that the LED lights turn on when I plug in the battery, but they only stay on for a moment (one second?) and then they fade out, as if a capacitor is discharging. Also, my TX connects (I think? It makes a sing-song noise) but the GPS Mode Green LED flashes continuously, and none of the buttons seem to do anything.

Also, just to be sure, the connection in question is the one I have highlighted, correct?

@Dude , @lordneeko , @peterbarker , @Orffyreus

I tested every wire of the cable in the above photo, from board to board with a DMM for continuity and all looked good. I had continuity and no shorts between the wires.

To me this makes it seem like it isn’t a problem with that connection. Unless there’s something I am missing.

Any other ideas? I am really stumped and July 10th is fast approaching. I was really hoping I could use this but I’m starting to worry that I cannot :frowning:

It always gets stuck on “getting bootloader sync” and can’t seem to sync with the bootloader.

Can you describe the behaviour of the LEDs on the flight board when
powering up? When the bootloader is active there should be a rapidly
flashing orange light.

Does the stm32 get very hot very quickly when powered on?

I suspect the stm32 might be fried.

@peterbarker

When I first power up, the LED on the flight board flickers orange for about 5 seconds, and the red/green LEDs turn on for about 1 second then fade off in about 1 second (2 seconds total).

Yes, the stm32 gets hot relatively fast. The video and wifi do both work from the webpage though.

Do you think it’s worth finding a spare STM32 board online?

When I first power up, the LED on the flight board flickers orange for about 5 seconds, and the red/green LEDs turn on for about 1 second then fade off in
about 1 second (2 seconds total).

Yes, the stm32 gets hot relatively fast. The video and wifi do both work from the webpage though.

Sorry, when I mean hot I mean “too hot to touch”.

Do you think it¢s worth finding a spare STM32 board online?

The fact it seems to be running the bootloader tells me that the stm32
should actually be OK. However, the bootloader isn’t ever detected by the
Sonix board. Whatever is on the board is good enough for the bootloader
to try to run… but whatever is on there doesn’t know how to run the
LEDs and doesn’t talk over the serial port.

You could gather another data point (and possibly rescue the board) by
connecting the stm32 board to a usb-to-serial adaptor and trying to
talk to it / flash it with APBootloaderClient.

@peterbarker Sounds difficult, but I’m willing to try.

[EDIT] Sorry, I made a mistake earlier, it’s the SONIX board that gets very hot, not the STM 32 board. The STM32 board doesn’t really get warm at all.

I also went online and bought another sonix board. Maybe that was frivolous but I really want to get this up and running soon!

Either way, is there an instruction link to the flashing process you mentioned? I find the wiki a little difficult to browse.

@lordneeko @peterbarker @Dude @Orffyreus

My new Sonix board came in, and the drone still does the same thing. It’s definitely the STM32 board?

I checked the wiki, I can’t find the process to flash the STM32 board. Can anyone provide me with a link?