Cannot enable logs

Hi APM 2.5, having completed my first 3.1stabalised test hover for 3 minutes I tried to download some logs to help diagnose a few issues with motors glitching but found I had no logs enabled. I have tried to enable the logs through logbitmask and through the terminal. Having selected default + motors in the bitmask I checked in terminal and got logs] logs enabled none: I have tried enable **** command but that does not work either. Any ideas?

BTW When I open up Terminal and connect I get the message Dataflash not entered
When I go into Log Bitmask or advanced parameters and change the setting to default (for example) I then write the setting to the APM change the log setting to something else then Refresh and it shows the setting I have made. When I open the log download I get the message “no logs enabled”

Do you mean ‘No dataflash inserted’?

can you save your parameter file and post that here? also do you have telemetry?

can you please go to CLI, and connect to the APM once it is connected, press reset, and watch as it goes through the start-up, see if there are any errors, and post them back here. Thanks

If I do reset will it delete my settings? I do not have telem. Cannot upload a file with the extension .param. What shall I do?

Do you mean ‘No dataflash inserted’?[/quote]
Yes exactly that

Anyway whilst waiting for a reply to my earlier question I connected to cli and pressed reset on the apm. The result was just a load of computer strings scrolling on the screen that never stopped. I left it to run for 2 hours. In the end I just disconnected, reloaded 3.1 and re set up. Checked logs again and although I can set to default in advanced params when i check in cli I get the message 3no dataflash inserted 3Arducopter 3.1. Also I cannot upload the param file as the forum will not allow it.

Sorry to be impatient but for my peace of mind is anyone working on this please?

Do you mean ‘No dataflash inserted’?[/quote]
Yes exactly that[/quote]

Sounds like its faulty then - I don’t think you can remove the dataflash on the 2.5 boards.

I have just read somewhere else that it may be the 3.3 volt regulator that is faulty and can be replaced with this one " AMS1117 3.3V 1A Voltage Regulator" . How can I test if it is?

Here is how to test the 3.3V regulator