Cannot connect to a com port in mission planner


I last used MP in June 2018, have only had time to get back into it recently
finding that I cannot connect my APM plane pix 4 auto pilot to MP

I have tried following troubleshooting guides

uninstalled and reinstalled mission planner

I have tried downloading updates for my laptop usb ports, all seem to be working fine with usb and mouse inputs, not picking up the Auto pilot though

very frustrating

any help very welcomed


Issue SOLVED!!!

Simple mistake costing hours of pain

I was using an android charger cable rather then the apm cable

Easy fix hopefully this saves someone else the heart ache


Dear @Jack_Roohan, thanks for the topic!

I think I also have the same issue, can you please confirm.
So Mission Planner connection works fine, however APM Planner v2 does not connect.
I also use android charger cable.

Is the cable the main reason? How you found that?~
Can you please share the link of apm cable that solved the issue

Hi mate,

Yeah so i have 2 cables one which is just a standard android cable which i use to connect to the pixhawk, via the 433mhz reciever/transmitter.
The other cable is still an android attachment but has a cylindrical plastic piece on the cable (in-line) which seems to be the only way to connect directly to mission planner, which allows me to calibrate etc. I can’t find it atm but when i do ill post a pic

Oh sorry for that misinformative reply,

I find the cable and will upload a few pics in a minute
Please ignore my description of it in my previous post :smiley:

1 Like

So i connect this cable to my computer/laptop either radiolink with the tx or directly to the pixhawk board.
The difference seems to be in the android part of the cable if that makes sense


1 Like

Dear @Jack

Thank you sooo much!! I will try all the cables I have, hope I can find one that will work.

Really appreciate much your feedback

No worries
all the best :smiley: