Cannot connect mavlink

I’ve just recently gotten an APM2.5 and connected it up to my computer. It ran fine the first time when testing, but once I disconnected it to connect up the receiver and servos, it seems to have lost the ability to connect to my mission planner.

Mission planner is the most recent version, downloaded last night.
I have wiped the APM and reinstalled the firmware, but still no luck.
Trying to connect to the same com port it used to install the firmware.
Nothing is connected to my APM at the moment, just USB to computer.
Tested board by writing normal arduino code onto it, and it can communicate with my computer fine.

Can anyone think of why it is unable to connect and offer any solutions?

What do you have the baud rate set to? it should be 115200 for the USB connection,

Baud rate is set to 115200, and I have tested it with every other baud rate too without any luck.

Im having the same Problem. Except i never had a working connection. Baud rate is set to 115200 the Com Port works fine. I tried it on Windows 8 and 7 and no luck at all.

Any Ideas?

TheColonel: Do you mean Mission Planner or APM Planner 2.0. They are different programs.

My advice would be to install the drivers for windows for the serial port. Easiet way to do that is by downloading the installer for APM Planner 2.0

I recently had the same problem on a APM2.6 board. Could flash the board, verify the software, but could not connect. I found out that it was caused by a hardware error on board the APM, a TXB0104 (3.3 - 5 V) was misplaced, and had to be re-soldered into the correct position.